Highlighted
Contributor
Contributor

Can't login to orchestrator client with error "${message}"

Hello, i just deploy vRO 8.0.1 and get this error and try again with 8.1 with same result:

2.png

Validate config is perfect:

1.png

When I click "start orchestrator client", I am redirected to a page with the input of admin creds of my vCSA, after entering creds like administrator@vsphere.local with pswd, i got "${message}" in a center of page.

Authentication provider looks like this:

3.png

I try look at /vmware/vsphere-client/logs/ but none of logs there are registering this issue.

Also when i try open link with vmware-cip nothing happens.

0 Kudos
6 Replies
Highlighted
VMware Employee
VMware Employee

Hi,

Could you check if the time settings in your vCSA and vRO appliances are correct?

0 Kudos
Highlighted
Expert
Expert

Hey there,

i experience same issues when there was a problem with talking to SSO. I don't want sound bad or anything like this, but , if i were you i would leave 8.0.1 and install 8.1 i spent 3 weeks on configuring 8.0.1 things, and there was always something ... like the issue with root passwd being expired for example.

Once i switched to 8.1 a lot of issues are now gone.

--- @blog https://grzegorzkulikowski.info
0 Kudos
Highlighted
Contributor
Contributor

Time diff is about 4 mins, vCSA get time of my ntp server, vRO get time from somewhere, try to set ntp for vRO, but failed, commands from Enable or Disable Time Synchronization of vRealize Orchestrator​ are not recognisable. But i think 4 mins diff is ok for tokens or something like.

0 Kudos
Highlighted
Contributor
Contributor

I experience same issues like with root passwd being expired in 8.0.1 (KB76870) and plus subj of tis post. Than i switched to 8.1 and nothing changed, except problem in kb76870 are gone now.

0 Kudos
Highlighted
Expert
Expert

not sure if 4 mins is a lot, i would assume so actually.

i wonder why it has failed the ntp time sync for you.

VMware Knowledge Base

any chance this would work ?

any chance you can check with ntpq -p or ntpdc  if that ntp sync is on ? You are syncing to esxi or to ntp ?

--- @blog https://grzegorzkulikowski.info
0 Kudos
Highlighted
Expert
Expert

i dit not see ntpq , ntpdc on vro appliance to actually check this in some way, but i did those steps to apply the ntp, now, can you tell how you did it ?

# vracli ntp status

vro816.greg.labs:

----------------------------------

systemd NTP configuration:

      Local time: Fri 2020-05-01 11:19:22 UTC

  Universal time: Fri 2020-05-01 11:19:22 UTC

        RTC time: Fri 2020-05-01 11:19:22

       Time zone: Etc/UTC (UTC, +0000)

Network time on: yes

NTP synchronized: yes

RTC in local TZ: no

----------------------------------

ESXi time sync configuration: Disabled

----------------------------------

root@vro816 [ ~ ]# cat  /etc/systemd/timesyncd.conf

# Automatically generated. Do not edit.

# Please use 'vracli ntp' command to update this configuration.

[Time]

NTP=

root@vro816 [ ~ ]# vracli ntp systemd --set 192.168.1.243

Updating systemd NTP configuration with the following servers: ['192.168.1.243']

root@vro816 [ ~ ]# vracli ntp status

vro816.greg.labs:

----------------------------------

systemd NTP configuration:

      Local time: Fri 2020-05-01 11:21:28 UTC

  Universal time: Fri 2020-05-01 11:21:28 UTC

        RTC time: Fri 2020-05-01 11:21:28

       Time zone: Etc/UTC (UTC, +0000)

Network time on: yes

NTP synchronized: yes

RTC in local TZ: no

----------------------------------

ESXi time sync configuration: Disabled

----------------------------------

root@vro816 [ ~ ]# cat  /etc/systemd/timesyncd.conf

# Automatically generated. Do not edit.

# Please use 'vracli ntp' command to update this configuration.

[Time]

NTP=

root@vro816 [ ~ ]# vracli ntp apply

Executing cluster command to update NTP configuration ...

vro816.greg.labs:

        ESXi time sync ... Disabled

        Systemd NTP time sync ... Enabled

cat  /etc/systemd/timesyncd.conf

# Automatically generated. Do not edit.

# Please use 'vracli ntp' command to update this configuration.

[Time]

NTP=192.168.1.243

--- @blog https://grzegorzkulikowski.info
0 Kudos