holashh
Enthusiast
Enthusiast

Add orchestrator server with multi-node plug-in error - java.lang.NullPointerException

Hi all,

I have fresh installation of vRO 6.0.2 for testing purposes.

I have to test all our features and one of these is interconnection with multi-node plug-in.

My case is: I have one instance of vCO in version 5.1 and multi-node plug-in in version 72 (the latest one for this build) and trying to connect to my new vRO 6.0.2 (with build-in multi-node plug-in).

I am able to connect server and I see him in inventory, but when I try to generate a proxy workflows, I got the error

java.lang.NullPointerException (Workflow:Add an Orchestrator server / Add host (item0)#14)

Here is server.log output:

2015-09-09 21:44:03.426+0200 [http-bio-10.77.38.46-8281-exec-3] INFO  {} [Execution] Executing workflow 'Add an Orchestrator server'

2015-09-09 21:44:03.426+0200 [org.springframework.jms.listener.DefaultMessageListenerContainer#0-2] INFO  {} [Execution] Invoking workflow handler.8acda6ae4fb305de014fb3a2ed62023e

2015-09-09 21:44:03.714+0200 [WorkflowExecutorPool-Thread-27] INFO  {Add an Orchestrator server:8acda6ae4fb305de014fb3a2ed62023e:eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86:[eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86]} [Config_Network] get Properties:

2015-09-09 21:44:03.714+0200 [WorkflowExecutorPool-Thread-27] INFO  {Add an Orchestrator server:8acda6ae4fb305de014fb3a2ed62023e:eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86:[eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86]} [Config_Network] getRemoteCertificate:

2015-09-09 21:44:03.729+0200 [WorkflowExecutorPool-Thread-27] INFO  {Add an Orchestrator server:8acda6ae4fb305de014fb3a2ed62023e:eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86:[eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86]} [Config_Network] certificated found:1

2015-09-09 21:44:03.729+0200 [WorkflowExecutorPool-Thread-27] INFO  {Add an Orchestrator server:8acda6ae4fb305de014fb3a2ed62023e:eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86:[eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86]} [Config_Network]  - Common Name (6 characters min) = vro_server

2015-09-09 21:44:04.051+0200 [WorkflowExecutorPool-Thread-27] INFO  {Add an Orchestrator server:8acda6ae4fb305de014fb3a2ed62023e:eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86:[eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86]} [Config_Network] Imported certificate from X.509 into dunes keystore

2015-09-09 21:44:09.208+0200 [WorkflowExecutorPool-Thread-27] WARN  {Add an Orchestrator server:8acda6ae4fb305de014fb3a2ed62023e:eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86:[eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86]} [RestTemplate] GET request for "https://vro_server:8281/vco/api/inventory/System/Workflows/" resulted in 404 (/vco/api/inventory/System/Workflows/); invoking error handler

2015-09-09 21:44:09.208+0200 [WorkflowExecutorPool-Thread-27] WARN  {Add an Orchestrator server:8acda6ae4fb305de014fb3a2ed62023e:eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86:[eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86]} [ProxyWorkflowManager]

2015-09-09 21:44:09.208+0200 [WorkflowExecutorPool-Thread-27] INFO  {Add an Orchestrator server:8acda6ae4fb305de014fb3a2ed62023e:eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86:[eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86]} [SCRIPTING_LOG] java.lang.NullPointerException (Workflow:Add an Orchestrator server / Add host (item0)#14)

2015-09-09 21:44:09.208+0200 [WorkflowExecutorPool-Thread-27] WARN  {Add an Orchestrator server:8acda6ae4fb305de014fb3a2ed62023e:eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86:[eaef3c7d-c71e-4fa9-b70a-1ac3d807ba86]} [WorkflowItemTaskRunner] Script execution error on workflow : Add an Orchestrator server / 'Add host'(item0) : java.lang.NullPointerException (Workflow:Add an Orchestrator server / Add host (item0)#14)

Should this be caused by missing firewall rules?

Thanks,

Jan

Tags (1)
0 Kudos
1 Reply
igaydajiev
VMware Employee
VMware Employee

Most likely it is the version of the plugin vs the version of target vRO instance.

It will work if both vRO versiona are same 6.x and latest multi node plugin is used

It should work if one vRO  is 5.5.x ant the other is 6.x (did not test it) and you use latest avaialbe Multi node plugin

Quite sure it won't work in case of 5.1 -> 6.x (Certain pluign funcitonality like generation of workflows uses same API as vRO Workflow Designer which got changed between versions. Meaning that if you are not able to conect vRO Server 6.0.x with vRO client 5.1 plugin also wil lnot be able to work.

0 Kudos