maaca
Enthusiast
Enthusiast

Add a database WF fails when adding PostgreSQL

Jump to solution

Hello community,

Add a database workflow fails with error:

com.vmware.o11n.plugin.database.DatabaseException: java.sql.SQLException: No suitable driver found for jdbc:postgresql://XXXXXXXXXX (Dynamic Script Module name : addDatabase#8)

when I'm trying to register PostgreSQL database. I'm running vRO 8.1.0.

Somebody forgot to pack a PostgreSQL library, it is similar story to MySQL and it is missing by deign, or I've messed up something?

0 Kudos
1 Solution

Accepted Solutions
iiliev
VMware Employee
VMware Employee

Hi,

PostgreSQL JDBC driver is not forgotten, the vRO server itself runs on PostgreSQL. I tried this workflow on my 8.1 instance, and it completed successfully.

You can get such error not only when the driver is missing but also in some other cases, for example, if you provided a malformed connection URL. Could you show what parameters you used to run this workflow? In particular, make sure the connection URL is correct; it should look like jdbc:postgresql://10.20.23.33:5432/db-test

View solution in original post

0 Kudos
2 Replies
iiliev
VMware Employee
VMware Employee

Hi,

PostgreSQL JDBC driver is not forgotten, the vRO server itself runs on PostgreSQL. I tried this workflow on my 8.1 instance, and it completed successfully.

You can get such error not only when the driver is missing but also in some other cases, for example, if you provided a malformed connection URL. Could you show what parameters you used to run this workflow? In particular, make sure the connection URL is correct; it should look like jdbc:postgresql://10.20.23.33:5432/db-test

0 Kudos
maaca
Enthusiast
Enthusiast

Hi,

thank you for the hint. Error was between keyboard and chair, as usually. I forgot to specify the DB on the DB server...

0 Kudos