ahola
Enthusiast
Enthusiast

AMQP: Messages stuck due to unack'ed message

Jump to solution

Hi there,

We have taken the Library/AMQP Samples/Wait for a message - modified it to run inside a loop as we want to continuously subscribe to messages inside a RabbitMQ queue. Here is the behaviour that we have noticed:

1. Works great for a long time w/o any issues for the following sequence of events:

- publish message to queue (from an outside client)

- vCO picks up the above message

- publish message to queue (from an outside client)

- vCO picks up the above message

...

2. Has issue when there are multiple messages published at one time from outside:

- publish say 10 messages to queue (from an outside client) - while the subscriber is running inside vCO

- vCO picks up the first message

- vCO is stuck waiting (although there are nine more messages waiting to be picked up)

When I try to debug this via the RabbitMQ console, I see that there is one unack'ed message which is blocking all of the messages from being processed. Now, when I do a "Force connection close" from RabbitMQ console, it moves further along with maybe one or two more messages and then gets stuck again with the same issue.

This is not an issue when I run a publisher and subscriber from outside vCO. I am guessing there is an issue with the auto-acknowledgement part in the AMQP plugin.

Appreciate if you could look into what the issue is. This is consistently reproducible at my end.

Cheers,

Shashi

0 Kudos
1 Solution

Accepted Solutions
jvassev
Contributor
Contributor

Hi,

There was a known issue with the AMQP plugin with receiving messages using a trigger. Do you happen to know the exact version of the plugin you are using?

I can try to send you a version that contains the fix.

Regards,

Julian

View solution in original post

0 Kudos
2 Replies
jvassev
Contributor
Contributor

Hi,

There was a known issue with the AMQP plugin with receiving messages using a trigger. Do you happen to know the exact version of the plugin you are using?

I can try to send you a version that contains the fix.

Regards,

Julian

View solution in original post

0 Kudos
ahola
Enthusiast
Enthusiast

Julian -

We are using following version: AMQP 1.0.1.197.

Thanks.
Shashi

0 Kudos