jphillips5
Contributor
Contributor

vCops data collection issue after cluster

Good afternoon everyone!

     Having a little bit of an issue with vCO at the moment. I implemented a couple of clusters for my hosts that are using DRS. After doing this, I noticed health and resource data are now missing from my Operations manager dashboard. One of my hosts have also disappeared from the view also.

Right now we are waiting to see if vCO is just collecting data for the new setup.

Any thoughts?

Thank you

0 Kudos
3 Replies
mark_j
Virtuoso
Virtuoso

The proper abbrev was vCOps, now is vROps. vCO is now vRO.

  1. What version are you running? Maintenance mode might have also thrown a host in to maint mode, which would indicate the host as not collecting and in maint mode.
  2. How are you on licensing? Is the host or OSI licensed or are you short?
  3. Go in to the environment overview view and sort by host systems.. see if you've got them in the resource list for the object kind.

#1-3 assumes you actually had it collecting properly in the first place.

Have you gone back to the beginning and ensured you're not collecting from vCenter using a limited-permission/scope account? If the account cannot see the resources in vCenter, vROps won't collect them.

If you find this or any other answer useful please mark the answer as correct or helpful.
0 Kudos
jphillips5
Contributor
Contributor

Thank you for the response

I apologize for the lack of information in my initial post, but here are some additional details

I am running a fully licensed vCenter Operations Manager (Enterprise) appliance (deployed .ova that deployed the vApp as a whole) 5.8.4, all of the other elements (vCenter, ESXi, etc) are licensed also

We were fully collecting data from the environments prior to my implementation of the DRS clusters within the Datacenters. The set up prior to the deployment of the DRS clusters were as follows (all of the elements in the vCenter are on the same subnet and were successfully pinging eachother):

vCenter

     DataCenter 1

          ESXi host

     DataCenter 2

          ESXi host

          ESXi host

     DataCenter 3

          ESXi host

          ESXi host (hosting operations appliance vApp)

          ESXi host (hosting vCenter)

Now in this setup we were able to collect Health, Risk, and Efficiency data without issue and were getting some great results for future planning (that was running for about two months). The setup was changed to this:

vCenter

     DC1

          ESXi Host (without DRS)

     DC2

          DRS Cluster

               All hosts

     DC3

          DRS Cluster

               All hosts with operations vApp still on the host it was on previously

Now I noticed when implementing the DRS cluster, it removed the vApp that was exclusive to the operations .ova that was deployed.

After DRS was setup on the hosts stated (maybe a day or two after) there was a complete loss of data collection. I looked around VMware and the internet and unfortunately could not come up with any documentation stating the issues/risks with running DRS and Operations Manager together.

Again thank you for the response and any help is appreciated.

0 Kudos
mark_j
Virtuoso
Virtuoso

And you can log in to the vSphere and Custom UI ok? If so, you'll likely see errors in the collector / adapter / vmware_*  adapter instance logs... which can be accessed from the Custom UI's Support > Logs area. It sounds like you'll want to run the vApp repair steps to fix the vApp (adding the VMs back in to it), as the VAs get their network config from that. Between these things, I'm thinking you'll get closer to where you want to be.

If you find this or any other answer useful please mark the answer as correct or helpful.
0 Kudos