plaintoasty
Contributor
Contributor

Unable to communicate with server -- provider not yet setup. Agent might still be initializing.

Any one come across this error with EPO agents on vROps 6.3?

"Unable to communicate with server -- provider not yet setup. Agent might still be initializing. "

This is the first time I have installed EPO agent which I tried after an upgrade from 6.2 to 6.3.

This is the same on both Linux and Windows VMs.

Under EP Ops Adapter in Inventory Explorer all the collection states are showing as collecting and receiving.

Regards

James

0 Kudos
9 Replies
sxnxr
Commander
Commander

Are you installing the 6.3 EOPS agent?

0 Kudos
npiron
Enthusiast
Enthusiast

Hello, did you find a solution to this issue?

I have the exact same issue...

Thanks a lot!

0 Kudos
Neird
Contributor
Contributor

Hi, I have same problem with vROps 6.4. Did anyone found a solution?

Thank you

0 Kudos
daphnissov
Immortal
Immortal

This is the error you get when you haven't gone through the setup process to get an access token from vROps. Please post some more information about your setup to see where the problem lies.

0 Kudos
Neird
Contributor
Contributor

Thanks daphnissov,

I'm using vROps 6.4

Installing the agent with windows 2012

Here's the error I found on the agent.log

11-01-2018 21:22:01,997 CST INFO  [main] [AgentClient] Successfully obtained token: <Token>

11-01-2018 21:22:02,528 CST INFO  [main] [PlatformToken] Loading the platform token from C:\ProgramData\VMware\EP Ops Agent\epops-token

11-01-2018 21:22:02,528 CST INFO  [main] [PlatformToken] Current platform token is <Token>

11-01-2018 21:22:02,528 CST INFO  [main] [AgentClient] - The agent loaded an existing token

11-01-2018 21:22:02,528 CST INFO  [main] [AgentClient]     <Token>

11-01-2018 21:22:02,559 CST INFO  [main] [AgentClient] - Testing secure connection ...

11-01-2018 21:22:02,731 CST INFO  [main] [ServersManager] Support RRDNS:true  Fail period:5  Down period interval:10 

11-01-2018 21:22:02,747 CST INFO  [main] [ServersManager] Agent support RRDNS

11-01-2018 21:22:02,747 CST INFO  [main] [ServersManager] Servers are : Preferred(Server[IP:<IPAddress>  isDown:false  lastSuccess:Thu Jan 11 21:22:02 CST 2018  ]) - []

11-01-2018 21:22:02,872 CST WARN  [main] [X509TrustManager] Fail the connection because the received certificate is not trusted

11-01-2018 21:22:02,872 CST INFO  [main] [BizappCallbackClient] The following server certificate thumbprint will be trusted during registration: <Thumbprint>

11-01-2018 21:22:02,872 CST INFO  [main] [BizappCallbackClient] Found a certificate thumbprint that matches the one provided in the properties file.

11-01-2018 21:22:02,997 CST INFO  [main] [ServersManager] Successfully sent to server Server[IP:IPAddress> isDown:false  lastSuccess:Thu Jan 11 21:22:02 CST 2018  ]

11-01-2018 21:22:03,012 CST ERROR [main] [AgentClient] - Connection failed.

11-01-2018 21:22:03,012 CST ERROR [main] [AgentClient] Unable to complete automatic agent setup. Unable to connect to server.

org.hyperic.hq.bizapp.agent.client.AskQuestionsUtil$AutoQuestionException: Unable to connect to server.

Thank you

0 Kudos
daphnissov
Immortal
Immortal

So you aren't trusting the thumbprint of the cert vROps is presenting. When you install the agent, did you input the proper thumbprint? If not, you'll need to edit agent config file to insert it, or run C:\ep-agent\bin\ep-agent.bat setup in interactive mode and it should prompt for it.

0 Kudos
Neird
Contributor
Contributor

Hi daphnissov,

I tried to use the C:\ep-agent\bin\ep-agent.bat setup  but I got Invalid username/password error.

Do the account used to install the agent also needs login access to the vROps Server? I'm using account which has AgentManager role but do not have login to the vrops server itself.

Thank you,

Dan

0 Kudos
daphnissov
Immortal
Immortal

Ok then you need to look at that account because it doesn't have the required permissions. The documentation has what is required.

0 Kudos
GayathriS
Expert
Expert

The login account of agent machine should have access on Vrops interface as well.

eg :

you login to windows machine with AD account while installing EPOPS agent , the same account should have admin privileges on vrops .

This will fix your problem

Please mark this as "correct" or " Helpfull" if this answers your query.

regards

Gayathri

0 Kudos