gkman
Enthusiast
Enthusiast

Since Update to 6.2 (from 6.0) Not receiving data from vcenter

Jump to solution

Hello,

I recently updated our vRealize Appliance following these articles: How To Patch Or Upgrade VMware VRealize Operations Manager (vROps) ? | Settlersoman - A Settler In T... and Upgrading vRealize Operations – that virtual boy.

When following the instruction I was faced with the question of which version to download- with windows based remote collectors or without. after consulting on the forum (Updating vrops appliance - what should I do regarding remote collectors?) I ended up upgrading with:

vRealize Operations Manager - Virtual Appliance Operating System upgrade - vRealize_Operations_Manager-VA-OS-6.2.0.3542056.pak

vRealize Operations Manager - Virtual Appliance upgrade (without Windows based RC) - vRealize_Operations_Manager-VA-6.2.0.3528954.pak

After the upgrade we noticed that vrops did not receive any updates from our vcenter (version 6.0.0 3339083 installed on windows server), The graphs, badges and metrics either are unavailable, with old values or just empty

Capture2.PNG:Capture.PNG

I must admit I don't understand all that much about vrops. I mainly use some of the dashboards here and there to troubleshoot different errors, but I started poking around and got to this screen from administration > cluster management, and from it, it seems that vrops lost connection with our vcenter:

Capture3.PNG

I took a snapshot before upgrading- but I was told it may not work since the upgrade updates the database as well.

what should I do?

1 Solution

Accepted Solutions
MauroBonder
Leadership
Leadership

My recommendation:

Open a SR on support VMware. Maybe will be needed an adjust on database postgres.

Thanks

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado

View solution in original post

0 Kudos
12 Replies
MauroBonder
Leadership
Leadership

Hello,

Did you try to remove and create a new adapter of vCenter ?

Thanks

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
0 Kudos
ooajala
Enthusiast
Enthusiast

You can first try to Stop and Restart data collection under Solutions > VMware vSphere > You will see all vCenter adapters at the bottom > Click on the Red stop icon and wait for 5secs and then click on the green play icon.


Give it some time (about 5mins) and monitor the collection state and status to Start collecting and receiving data.

If that doesn't work, then the next option would be what MauroBonder‌ suggested.

-- *** If you like my response, please click "Like" below, if you think I answered your question to the best of my abilities, please mark post as Correct Answer *** 3x vROps Environments implemented across my organization. VDI vROPs 6.6 ::: Epic vROPs 7.0 ::: Department vROPs 7.0 vROPs Adapters in use: EpicCare & Horizon View Adapter 6.5
0 Kudos
gkman
Enthusiast
Enthusiast

No, like I said I am very new to vrops, so up until now I didn't even know about the vcenter adapter.

can I add it as another adapter or do I have to replace the old one? are there any possible consequences I should be worried about? (I don't know like what - deletion of custom dashboards?)

in anycase I tested the connection and test was successful, but the collection state is stuck on "starting"

0 Kudos
ooajala
Enthusiast
Enthusiast

gkman‌ If it is the same vCenter, you can't add it as another adapter, not something I have attempted before because you might end up with a lot of duplicate objects in vROps.

Yes, You have to replace the old. There are no consequences of doing this. I can only tell you that when deleting the vCenter adapter, there is a check box to remove all related object data, you can leave it unchecked so that when you re-add the adapter, all objects and historical data remain so it doesn't have to get repopulated. You don't have to worry about dashboards and views that are related to the adapter because once you add the adapter back, the data within the views and dashboards will repopulate.

You can always reload the screen to get fresh update on the status, if the test is successful, like I said, give it a couple of minutes and the Collection State should turn to "Collecting" and Collection Status will be "Data Receiving"

-- *** If you like my response, please click "Like" below, if you think I answered your question to the best of my abilities, please mark post as Correct Answer *** 3x vROps Environments implemented across my organization. VDI vROPs 6.6 ::: Epic vROPs 7.0 ::: Department vROPs 7.0 vROPs Adapters in use: EpicCare & Horizon View Adapter 6.5
MauroBonder
Leadership
Leadership

Remove and Re-Add Adapter Instance

                Remove and Re-Add (X / +)

                Home > Administration > Solutions > Choose Adapter > Configure (click the gear icon) >

        Record the Display Name, Description, vCenter Server IP Address, Credential and expand Advanced Settings and note the Collectors/Groups configuration (it may be Default collector group)

        Remove:

        Select the Adapter Instance

        Click the "X" icon to delete the instance.

        Do not check the "Remove releated objects" box.

        Click the Yes button

        Click the "X" icon to delete the instance.

        Add:

        Click the "+" icon to add the instance.

        Enter Display Name, Description, vCenter Server IP Address, Credential and expand Advanced Settings and select the same Collectors/Groups configuration as previously used (it may be Default collector group)

       Click the "Test Connection" button

       Review and Accept the Certificate

       (You can highlight and copy the certificate information and save it for a record)

       Click the "Save Settings" button

       If prompted, select to Force the registration

       Click the "Close" button

4. Start Collection

                Home > Administration > Solutions > Choose Adapter

        In the VMware vSphere vSphere Solution Details panel, select the adapter instance.

        Click the Green Arrow/Play "Start Collecting" Icon

        Confirm that the Collection Status changes to Data Receiving

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
gkman
Enthusiast
Enthusiast

Thanks for the helpful reply's.

I followed MauroBonder‌ instructions, and it seems it got the adapter back to work (state is collecting and collection status is data receiving)

However metrics and graphs are still left un-updated.

looking at one of the dashboards I noticed it wasn't collecting:

Capture1.PNG

so I decided to reboot the appliance- when it came back up- the adapter collection state was back on being stuck on "starting" and collection status was back to "none"

what now?

0 Kudos
MauroBonder
Leadership
Leadership

My recommendation:

Open a SR on support VMware. Maybe will be needed an adjust on database postgres.

Thanks

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado

View solution in original post

0 Kudos
gkman
Enthusiast
Enthusiast

thanks for the help

Serg01
Enthusiast
Enthusiast

I have this trouble too. After update vrop from 6.0 to 6.2, vrops did not receive any data from my vcenter (5.5).

I Remove and Re-Add Adapter Instance, collecting data has started, but all my data has gone.

How i can take back my collected data?

0 Kudos
Serg01
Enthusiast
Enthusiast

Check box to remove all related object data was unchecked, but after i re-add the adapter, all objects and historical data was deleted..

0 Kudos
MauroBonder
Leadership
Leadership

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
0 Kudos
MauroBonder
Leadership
Leadership

FYI https://kb.vmware.com/kb/2144582

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
0 Kudos