BAronson
Contributor
Contributor

Operations Manager Deployment trust errors

Hello,
I am starting fresh with an Operations Manager 5 deployment.  I downloaded the OVA, setup my ip pools, and followed the tutorial on setup to the letter - http://www.youtube.com/watch?v=pwRdGDhI0lc

I am running into an error coming from the UI VM box, which says failed to setup trust to <analytics IP address>.  It then proceeds to say it can't get to this address.  However, when I log into the UI VM box, i can ping the IP address.

Does anyone have any ideas?

0 Kudos
3 Replies
jbberry
Contributor
Contributor

Holy crap that was a pain to fix...I've been figting with that for the past 12 hours to get it working, but it's finally going. I'll try and describe what I did, hopefully it'll make sense to you if you're a Linux guy at all.

Deploy the vApp

Interrupt the FIRST boot of the UI VM, and boot into single user mode

Move the vaos, vami-*, and vcops* services out of /etc/init.d into a backup folder someplace

Reboot the machine

It'll boot up, and use the blue-screen to configure your networking.  Make sure to do IP as the very first thing, don't do gateway or anything else first.

Exit the network config app, then login to the console

Generate your SSH keys

Manually SCP them over to the other server's authorized_keys file

Manually SCP the other server's keys into the UI's authorized_keys file

Edit the /opt/vmware/etc/init.d/vaos file and comment out the two lines that delete and generate the SSL keys again (lines 343 & 344 in mine)

Move all the files from your backup folder (step 3) back into /etc/init.d

Reboot the machine

0 Kudos
s1xth
VMware Employee
VMware Employee

Good information!! Thanks for sharing the fix.

Jonathan

<http://www.vmware.com/

http://www.virtualizationimpact.com http://www.handsonvirtualization.com Twitter: @jfranconi
0 Kudos
Grzesiekk
Expert
Expert

Hello,

jbberry posted great solutions on this. I thought i could make it more clear to others who might not know exactly how to proceed with this solution.

1) deploy VCOPS vAPP and start it. Keep an eye when the UI vm will power on, as at this time you should interrupt the booting process by, pressing 'space' key for example. Grub will pause, and you will be able to edit the kernel parameters. Select the first option, and press "e"

2.jpg

--

Select second line and press "e" again

http://desmond.imageshack.us/Himg39/scaled.php?server=39&filename=61905555.jpg&res=medium

--

Type "1" and press enter. This will load the UI vm in single mode

http://desmond.imageshack.us/Himg838/scaled.php?server=838&filename=83205674.jpg&res=medium

---

It will ask you for the password...."vmware" Smiley Happy

http://desmond.imageshack.us/Himg337/scaled.php?server=337&filename=98772154.jpg&res=medium

--

Execute

mkdir backup; mv /etc/init.d/vaos /etc/init.d/vami-* /etc/init.d/vcops* /root/backup

http://desmond.imageshack.us/Himg843/scaled.php?server=843&filename=62846720.jpg&res=medium

then reboot the UI vm

It should power on, and go to blue screen with some red background line  that network should be configured. Configure network IP.

Login to shell, root/vmware

ssh-keygen -t rsa to generate new key save it in the default directory

then copy the public key to the analytics box

scp /root/.ssh/id_rsa.pub root@analystics-vm-ip:/root/.ssh/authorized_keys

then copy key from the analytics box

scp root@analystics-vm-ip:/root/.ssh/id_rsa.pub /root/.ssh/authorized_keys

then

vi /opt/vmware/etc/init.d/vaos

you can press esc and type :set number

to see the line numbers, and go to the lines which jbberry mentioned, and hash 2 mentioned lines

press esc again and type :wq  [enter]

And the last step

mv /root/backup/* /etc/init.d/

type exit to see the main menu, do other network settings if needed dns/gw/hostname etc.

reboot the box.

This worked for me , so once again thank you jbberry for your time to figure this out !!!

---------

Other conclusion, this error should not appear if you have configured your network properly i assume. When i was trying to fix it i was deploying vcops several times and noticed that if i give for vapp proper network settings, so it can ping their gateway, this error is not showing up. I had a case where the portgroup where vcops was had wrong vlan, so it could not reach their gateway , but the vms could see eachother(here i had had to do this solution). When i put proper vlan number, vcops was installed without this error. Any ideas why this might be happening ?

--- @blog https://grzegorzkulikowski.info
0 Kudos