Highlighted
Commander
Commander

Monitoring SQL Server with SQL Plugin

Hi,

i have installed the SQL Plugin from the Solution Exchange to monitor our SQL Server.

I have one issue or question. Depends on how you interpret it.

I have a lot of messages that the service is down. But it is not the case. One minute later, i get the message that the service is up and running.

It looks like this in the graph.

pastedImage_0.png

pastedImage_1.png

I have checked the service and it was up and running at the time i receive the message. I didn´t have any idea why an whats going on. I could change the symptom defenition wait cycle, but i guess that is not the solution.

Did someone else had seen this before?

Frank

If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
4 Replies
Highlighted
VMware Employee
VMware Employee

Hi Frank,

What is the version of EPO/vROps? What particular service is in question?

I would rather check that connection from EPO to vROps is OK - agent.log could be helpful here.

Regards, Oleg

0 Kudos
Highlighted
Commander
Commander

Hi Oleg,

we are running Version 6.4. Also the EPO Agent is the latest Version.

I have checked the Log files and found on the related warnings the following entrys.

[MsSQLMeasurementPlugin] Unable to connect to the DB 'MSSQL$TMSM', review the sqlserver_name/instance/testdbcon options. Command execution terminated with erronous Exit Value: master
tempdb                                                                                                                    
model                                                                                                                     
msdb                                                                                                                      
db_TMSM                                                                                                                   

(5 rows affected)

org.hyperic.hq.product.PluginException: Command execution terminated with erronous Exit Value: master                                                                                                                    
tempdb                                                                                                                    
model                                                                                                                     
msdb                                                                                                                      
db_TMSM                                                                                                                   

(5 rows affected)

    at org.hyperic.hq.plugin.mssql.MsSQLDataBaseCollector.runCommand(MsSQLDataBaseCollector.java:208)

    at org.hyperic.hq.plugin.mssql.MsSQLDataBaseCollector.executeSqlCommand(MsSQLDataBaseCollector.java:93)

    at org.hyperic.hq.plugin.mssql.MsSQLMeasurementPlugin.checkServiceAvail(MsSQLMeasurementPlugin.java:235)

    at org.hyperic.hq.plugin.mssql.MsSQLMeasurementPlugin.getValue(MsSQLMeasurementPlugin.java:149)

    at org.hyperic.hq.product.MeasurementPluginManager.getPluginValue(MeasurementPluginManager.java:166)

    at org.hyperic.hq.product.MeasurementPluginManager.getValue(MeasurementPluginManager.java:294)

    at org.hyperic.hq.measurement.agent.server.ScheduleThread$MetricTask.run(ScheduleThread.java:600)

    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

    at java.util.concurrent.FutureTask.run(Unknown Source)

    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

    at java.lang.Thread.run(Unknown Source)

Do you have any idea whats going wrong?

Frank

If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
Highlighted
VMware Employee
VMware Employee

1. Regarding error message - mostly it's due to the account permission - EPO use service account (local system by default) to impersonate on the SQL instance. Check that instance in question either have System added to the Security--Logins or use the same account which is used to start SQL to start EPO agent.

2. Regarding service down - epo will provide service status once in 5 minutes. check windows event log if that is any errors indicating that SQL service for one of the instance might be restarted. if not the case, after correcting problem with the credentials, check the behavior.

Regards, Oleg

0 Kudos
Highlighted
Commander
Commander

Hi,

i think it is not an account or permission issue. Because the error message do not appear the whole day. And if i understand it right, than the end point agent try to resolve the content on the vm every 5 minutes.

So if there is a permission issue, the error message should pop up every 5 minutes. Or am i wrong?

What i saw is, that the collection takes more than the default 5000 ms. I try to change the agent.properties

scheduleThread.fetchLogTimeout=10000

Frank

If you find this information useful, please award points for "correct" or "helpful".
0 Kudos