Highlighted
Contributor
Contributor

Issues after restarting the vCOPS vAPP

Jump to solution

Hey there - I'm running vCOPS 5 -

I noticed that some VM's were showing 'no data' in their respective details panels..I read somewhere restarting the service was the way to fix this..

At the time I wasn't aware of the command-line way of restarting the service (from the Ui box vcops-admin restart), so I right clicked the vCOPS vAPP itself clicked shutdown, waited a while after it had done so and turned it back on.

Tried to log in using FQDN at the browser said web server not available - will redirect when possible.. shortly there after it kicked me to a 404 screen.

I verified in the vSphere Client that the IP's are static and different, I then logged into the UI box and ran a summary, it showed the Analytics VM having the same Ip address.. so I ran the repair tool (vcops-admin repair --ipaddress XXXXXXXXXXXXX) with the Analytics VM's address.. it said "repaired" after restarting the service again, but after another summary view - showed the same thing.

I read that in v1 of vCOPS this was a known graphical mismatch - and to ignore it.  So -- what could be the issue?  Let me know (I've also already verified there is drive space)

Thanks in advance for any assistance !

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Immortal
Immortal

Leffingwell,

Can you check how much space is left on the /data partition of each VM?  the 404 error means a webservice started, but one of the background DB servers probably didn't.

If either /data is near or at 100% full, then you need to power off the vApp ... add a new disk ... power it back on.

When you add a disk, take all the default settings ... and preferably choose the Eager Zero Thick style (performs faster than the other two).

Best Regards,

Jon Hemming

View solution in original post

0 Kudos
4 Replies
Highlighted
Immortal
Immortal

Leffingwell,

Can you check how much space is left on the /data partition of each VM?  the 404 error means a webservice started, but one of the background DB servers probably didn't.

If either /data is near or at 100% full, then you need to power off the vApp ... add a new disk ... power it back on.

When you add a disk, take all the default settings ... and preferably choose the Eager Zero Thick style (performs faster than the other two).

Best Regards,

Jon Hemming

View solution in original post

0 Kudos
Highlighted
Contributor
Contributor

Thanks so much for the response, I had seen what you were referring to in another post before I made this thread - unfortunately human error was the cause of this. I had looked up the volume capacity on the UI VM not the Analytics VM by mistake.  You were correct that it was the disk being full Smiley Happy

A quick addition and voila - we were back in business!

0 Kudos
Highlighted
Immortal
Immortal

haha, good times.

Glad you got fixed up!

0 Kudos
Highlighted
Enthusiast
Enthusiast

Thanks, worked for me too Smiley Happy

0 Kudos