Highlighted
Contributor
Contributor

Cannot view Inventory Explorer with current rights

Hi all,

I am currently testing an issue we have been seeing in our vROPs clusters. It seems when an AD user tries to view the Inventory Explorer, it either times out or just continues to circle looking for objects. I had a ticket open with VMware and it looks like it is the permissions for the objects the group can see.

Currently we have 2 AD groups imported, and the roles are assigned to those groups.

So:

Group A = Admin group

Group B = Infrastructure group

Role A is assigned to Group A and can view all objects

Role B is assigned to Group B and has limited access to objects, specifically the adapters.

My AD account is only in Group A as I have confirmed within AD myself.

I have removed my AD user from vROPs and re-imported it. It takes a few mins, but the groups do sync and show up.

However, I still see Group A and Group B in the User Groups area. This should not be the case as AD only has Group A listed for me and not Group B.

1. Why is the system showing I am in both groups, when AD is showing only Group A? Do I need to wait for an actual sync to happen on the Authentication Sources?

Also,

Since I am in both groups A and B, the Inventory Explorer still times out or takes a while when looking through objects.

2. If you have 2 groups, one with full permissions to see all objects and one with half permissions, which group takes precedent?


Thanks!

Permissions.PNG

User Groups.PNG

0 Kudos
0 Replies