ranjitcool
Hot Shot
Hot Shot

vRealize Automation Simple install issue

Hello all,

I am using the vRA Wizard to install and I keep getting this error in database validation

"Another instance of the component is already installed on the server"

Now in the "Microsoft SQL Server" step I enter the Server name as  "IAAS\vrealizeinstance" (the vRealizeInstance is the db named instance I created during installation).

Attached is the picture - what am i doing wrong. When I enter the IAAS\vrealizeinstance it says "another instance is already installed" - when i change the name it errors out.

TCP/ip and named pipes is enabled for db.

vra-db-error.jpg

Not sure what is the issue.

Please advise,

Thanks

RJ

Please award points if you find my answers helpful Thanks RJ Visit www.rjapproves.com
Tags (2)
0 Kudos
5 Replies
Michael_Rudloff
Enthusiast
Enthusiast

It appears you enter the instance name in the field for the server name.

Server name: Would be the server SQL is installed on

Database name: Is where you would include the instance name

So if SQL is installed on your IaaS server, you would likely use

Server name: IaaS.domain.com

Database name: vrealizeinstance\DBName

DBName = whatever you want to call your database to be created ...

Screen Shot 2016-06-23 at 09.42.36.png

___ My own knowledge base made public: http://open902.com
0 Kudos
ranjitcool
Hot Shot
Hot Shot

Thanks Michael let me try that sounds promising ...

Please award points if you find my answers helpful Thanks RJ Visit www.rjapproves.com
0 Kudos
ranjitcool
Hot Shot
Hot Shot

Hey Michael,

Actually the DB server name allows you to specify the port and instance (which are optional) as dbname[,port][/instance]

Now the db name does not allow any special characters so having the instance name in there won't be allowed.

So back to being stuck..

Please award points if you find my answers helpful Thanks RJ Visit www.rjapproves.com
0 Kudos
GrantOrchardVMw
Commander
Commander

Is this a machine you've attempted to install vRA on before? This is a typical error message when other components are identified.

Grant

Grant http://grantorchard.com
0 Kudos
ealaqqad
Enthusiast
Enthusiast

I have just faced the issue today and it seems to be that the IaaS Web Component did not get removed as a part of the rollover. I have documented my case with the resolution at my blog in case others still hit the same issue: vRA Installation Error: Another instance of the component is already installed on this server.

Cheers,

Eiad Al-Aqqad

T: @VirtualizationT

B: https://www.VirtualizationTeam.com

Regards, Eiad Al-Aqqad Technology Consultant @ VMware b: http://www.VirtualizationTeam.com b: http://www.TSMGuru.com
0 Kudos