msergi8
Contributor
Contributor

vRA - Export and import virtual machines

When I export virtual machines of my virtual center on a csv file, all virtual machines appear with invalid_reservation, invalid_host_reservation and invalid_host_reservation_to_storege.

For do the export I select Infrastructure > Administration > Bulk Imports.

After export, I try to import but i have an error:

The reservation was not found: 'INVALID_RESERVATION' on line x.

Can anyone help me?

0 Kudos
10 Replies
msergi8
Contributor
Contributor

I created a reservation for vSphere but i continue with same error. It's necessary to create a minimum reservation? I have tried in different ways but continued with the same error...

0 Kudos
Catbou
Enthusiast
Enthusiast

We've once had a similar issue. We had to add/check the datastore on which the server resides in the resources of the reservation.

0 Kudos
msergi8
Contributor
Contributor

But you only had to select the datastore where the virtual machines resides? On the part of the reserve of this datastore, size, it's possible to reserve only 1? Or has to be at least the same size as the virtual machine?

I tried to select the datastore where the virtual machine resides and reserve only 1, and I continue with the problem.

Thanks.

0 Kudos
Catbou
Enthusiast
Enthusiast

What do you mean by "it's possible to reserve only 1"? Where does this 1 refer to?

0 Kudos
msergi8
Contributor
Contributor

When you do a reserver, the value that you put is in MB. I want to say that if it's possible put 1 MB of reserve?

0 Kudos
Catbou
Enthusiast
Enthusiast

No, that won't work. Can you try it with at least the size of the vm you want to import.

0 Kudos
msergi8
Contributor
Contributor

I put more than virtual machine size, and now I have this error:

Resource not found for the segment 'HostNicToReservations'.

Even so, I tried to import a virtual machine. Now it seems that does something, but when the process was finished I saw Status Invalid and in the "machines reamaning" column appears 1. If I see the error I can see that was no owner.... Any solution? I can reconfigure and put an owner?

Another question, If I try to delete others bulk imports, all was completed and imported machines are 0, I have this error:

Cannot complete the requested operation: Access denied (). Entity WorkQueue

Any solution?

Thanks.

0 Kudos
Catbou
Enthusiast
Enthusiast

Did you first generated a csv file? That's how we import our servers. We first generate a csv file from within bulk imports.

And then we select the server we want to import and copy paste it in a new csv which we import

In your export file you should see the invalid values which you can correct first.

You can add some additional properties in the csv if you want.

0 Kudos
msergi8
Contributor
Contributor

Yes, I generate a csv file before. After I open a csv file and only leave one machine. At this machine that I leave, the information is correct but  Deployment ID column has this conent: UNNAMED_DEPLOYMENT... This can be a problem?

After, if I import this csv file, with only one machine, status is completed but I can't see any machine....

On the other hand, if i review logs I can see this two errors:


CleanupActivity: Invalid schedule ID [0] is passed.


Access denied (). Entity WorkQueue

Inner exception: Exception has been thrown by the target of an invocation.

Inner exception: Access denied (). Entity WorkQueue


This second error appears if i try delete bulk imports. You know how can I delete this bulk import that doesn't work?

0 Kudos
Sany_1973
Enthusiast
Enthusiast

Getting error while trying to delete.

  • Cannot complete the requested operation: Access denied (classadmin@vsphere.local). Entity WorkQueue

vra 7.6

0 Kudos