schmitz3michael
Contributor
Contributor

vRA 8.x disable vCenter Customization Spec

Jump to solution

Hi,

I would like to disable the vCenter customization specs for a new Deployment and instead do my customization through a vRO workflow. I tried to set the property "customizationSpec: null" on the Cloud_vSpehre_Machine object in the Cloud Template, but it doesn't work.

Does anyone have an idea how to prevent vRA 8 from using the vCenter customization Specs?

0 Kudos
1 Solution

Accepted Solutions
caduncan
Enthusiast
Enthusiast

Hello,

Check your syntax. I think you want "customizeGuestOs: false" , rather than "null".

Also, are you using cloudConfig with cloud init? If so, this might offer some insight: vSphere static IP addresses in vRealize Automation Cloud Assembly (vmware.com)

 

View solution in original post

0 Kudos
9 Replies
xian_
Expert
Expert

Do you use static IP assignment?

0 Kudos
carl1
Expert
Expert

Simply leave the line out.  vRA does not use customization spec to set the hostname and IP address (like vRA 7 did).  vRA 8 sets it directly so, unless you need to change the root password or auto-join to an AD domain, you can just delete your customizationSpec line.

Carl L.

0 Kudos
schmitz3michael
Contributor
Contributor

@xian_, I use the static assignment

0 Kudos
schmitz3michael
Contributor
Contributor

@carl1, I think that's not right.

I've tried to delete the customizationSpec parameter from Cloud Template, but then vRA creates a customization spec on demand when creating a deployment and pass it to vCenter Server.

0 Kudos
xian_
Expert
Expert

That's how static assignment is implemented.

0 Kudos
caduncan
Enthusiast
Enthusiast

Hello,

Check your syntax. I think you want "customizeGuestOs: false" , rather than "null".

Also, are you using cloudConfig with cloud init? If so, this might offer some insight: vSphere static IP addresses in vRealize Automation Cloud Assembly (vmware.com)

 

0 Kudos
schmitz3michael
Contributor
Contributor

This parameter "customizeGuestOs: false" is exactly what I need.

But now the deployment takes much longer then with a working Custom Spec. Is there a way to see what it's doing and why it takes so much more time?

If I look into the request details it tooks 20 minutes from POWERING_ON (Task 31: Provision Compute) to the next step. It looks like it is waiting for a timeout or something...The Deployment with Custom Spec finished this step im 1:30 minutes.

0 Kudos
xian_
Expert
Expert

Try awaitIp: false

See Special Cloud Assembly properties 

0 Kudos
schmitz3michael
Contributor
Contributor

You guys are amazing, thank you so much for the quick help! 🙂

 

Now, the POWERING_ON Task just takes 1 second and my deployment is much faster. I've additionally set the parameter
awaitHostName: false, because I also set the hostname via a vRO workflow.

0 Kudos