Czernobog
Expert
Expert

vRA 8.1 - way to increase session timout limit when logged in via web interface?

I'm looking for an option to increase the global session timeout limit for all users, when logging in to the vRA web interface. I could not find an option anywhere, the only way to do this for a single user would be to acquire an access token from the authentication API and set the expiration there, however I want to set the value globaly.

Maybe this is something done in the vIDM management?

Also getting not getting redirected to the appliance url (tenant-1.domain.loc) instead of the child tenant url (tenant-1.org.domain.loc) after each automatic logoff would be nice 😕

Edit: I still don't know where the setting in the appliance is, but when using an LB, you can set the timeout there in your application profile.

Tags (1)
3 Replies
cdoola11
Enthusiast
Enthusiast

You can set by finding the path below like path.

1. First run "df -h"
2. fetch for the path like "/data/docker/overlay2/8b22b6c9b3e830c16c8959c7fad07f8895868a2e935f533145e0afcc78edee1b/merged/var/opt/apache-tomcat/conf/web.xml"

3. Update value for attribute "<session-timeout>" in above path like file

cat   /data/docker/overlay2/8b22b6c9b3e830c16c8959c7fad07f8895868a2e935f533145e0afcc78edee1b/merged/var/opt/apache-tomcat/conf/web.xml
craigso
Enthusiast
Enthusiast

I may be missing something, but when I do "df -h" I can't identify which disk has the apache config. They all end in */merged/ ?

running vra 8.1 patch 1.

0 Kudos
cdoola11
Enthusiast
Enthusiast

try below command and you may find two files. Update any one file.

find / -name 'web.xml'|grep '/merged/var/opt/apache-tomcat/conf/web.xml'