RebeccaW
Enthusiast
Enthusiast

vRA 6.2 not connecting to external Postgres; Postgres Appliance showing connected instead of just listening

This is getting to be the longest lab installation ever.

vRA CAFE appliance is no longer connecting to Postgres (it was previously)

"NOT Connected: Error connecting database on jdbc:postgresql://<HOST>:5432/vcac as user vcac: Connection refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections., Embedded DB is disabled"

vRA Postgres appliance however has the database as "Connected" when shouldn't it be disconnected there and have in the status that it is listening on all ports? How does one make it disconnect?

Attempt to log in to the vRA Console yields "Login failed. Please contact your System Administrator and report error code ixR1rJUa" since of course the appliance can't get to Postgres.

Anyone know of any way to get this back to functioning? We have no additional tenants at this point, just the default. Two appliances set up and have been working through some issues with the IaaS install so nothing done there yet.

0 Kudos
3 Replies
GrantOrchardVMw
Commander
Commander

I've typically seen that error code as the last few characters in the SAML token, indicating potential timesync issues.

I typically start with a DRS group to pull all of the vRA bits together onto the same host so that I can guarantee that there are no gremlins of this type in the environment.

Grant

Grant http://grantorchard.com
0 Kudos
RebeccaW
Enthusiast
Enthusiast

Oh sheesh it was postgresql.conf.  Listen_addresses was back to localhost. :smileylaugh::smileysilly:. Updated that back to * and CAFE can connect and one can log on to the console.

For our lab all the infrastructure is on the same host but that is a very good tip about setting up a DRS. Going to note that.

0 Kudos
ZenithVM
Enthusiast
Enthusiast

Faced similar issue :: In my setup the issue is multiple VIPs running on different load balancers. I had configured 2 diffrent F5LB setups with the same VIP.

Smiley Wink

0 Kudos