Gabrie1
Commander
Commander

You cannot delete this endpoint because 1 compute resources and 0 storage paths use it.

Jump to solution

Hi

Building my first vRA in homelab. Creating some domains, adding users, adding fabrics, reservations. All seems to be a bright sunny Sunday afternoon. But then I find a blogpost on how things really work with user permissions / groeps etc and I decided to start from scratch. Well, that is, I wanted to delete the tenants and build a new tenant, create new AD users, just to make everything much more clear to myself.

I started deleting stuff and now I'm running around in circles. I guess I somehow delete a component too early and I can't remove an Endpoint because "You cannot delete this endpoint because 1 compute resources and 0 storage paths use it.". When I look at "Infrastructure" - "EndPoints"  I see the endpoint "vCenter". When I hover over it and then click "view computeresources", I get an empty overview: "No data to display". But when I try to delete it, I get the error mentioned before.

Could it be that I just need to wait some time for syncing?

And seeing what happened to me now, is there a master upper God of the vRA kind of switch that will forcibly delete everything I ask for a clean out a tenant?

Gabrie

http://www.GabesVirtualWorld.com
0 Kudos
1 Solution

Accepted Solutions
Gabrie1
Commander
Commander

Why is it that I search and try for hours, post here and then find the solution seconds later Smiley Sad

Anyway, looks like a bug:  VMware KB: Deleting an endpoint in vRealize Automation fails with the error: This endpoint is being ... 

http://www.GabesVirtualWorld.com

View solution in original post

0 Kudos
4 Replies
Gabrie1
Commander
Commander

Saw a post where someone suggested there are Enterprise Admins, but I can't seem to find those.

http://www.GabesVirtualWorld.com
0 Kudos
Gabrie1
Commander
Commander

Why is it that I search and try for hours, post here and then find the solution seconds later Smiley Sad

Anyway, looks like a bug:  VMware KB: Deleting an endpoint in vRealize Automation fails with the error: This endpoint is being ... 

http://www.GabesVirtualWorld.com

View solution in original post

0 Kudos
sbeaver
Leadership
Leadership

Gabrie,

Isn't it amazing how that works  Smiley Happy   Power of the community!  Gets you the answer one way or another.

Steve Beaver
VMware Communities User Moderator
VMware vExpert 2009 - 2020
VMware NSX vExpert - 2019 - 2020
====
Co-Author of "VMware ESX Essentials in the Virtual Data Center"
(ISBN:1420070274) from Auerbach
Come check out my blog: [www.virtualizationpractice.com/blog|http://www.virtualizationpractice.com/blog/]
Come follow me on twitter http://www.twitter.com/sbeaver

**The Cloud is a journey, not a project.**
0 Kudos
xsamalix
Contributor
Contributor

The script on KB is not working for VRA 7 so if you are having same issue with VRA 7 do as below:

USE [VRA DB]
GO

DELETE FROM [dbo].[Host]
      WHERE HostName = 'ESXIHOSTNAME'
GO

Thanks

0 Kudos