DLally
Enthusiast
Enthusiast

Variables/input not passing to vCO

We're building a script to change the name of a server during the stub building.  The orchestrator workflow runs fine when we manually input the variables from vCO, but when we call the workflow from vCAC during building it kicks off the workflow but fails immediately.  The logs show none of the variables/inputs were populated.  Is there anything anyone knows I could check?  This has worked before, we just made some improvements to the workflow to query a SQL database.  But at this point I'm dead in the water, since no variables are being passed.

One thing as well is I'm using the same variables I used before on the same workflow, before I made any changes.

Some logs I've seen.  the Invalid application code error is just due to no inputs passing through, causing it to fail, so that part is not too helpful. 

Workflow "WFStubBuildingMachine" failed with the following exception:

DynamicOps.VcoModel.Common.VcoException: Error executing vCenter Orchestrator workflow: Invalid Application Code, please enter an application code. (Workflow:-Test-Naming / Scripting (item4)#7)

   at DynamicOps.VcoModel.Common.VcoWorkflowExecutor.ThrowExecutionFailure(String messageKey, Object jsonResponse)

   at DynamicOps.VcoModel.Common.VcoWorkflowExecutor.WaitAndGetExecutionResult(VcoWorkflowExecutionToken executionToken, Int64 timeout)

   at DynamicOps.VcoModel.Common.VcoWorkflowExecutor.WaitForCompletionAndSetOutput(VcoWorkflowExecutionToken executionToken, Collection`1 outputParameters)

   at DynamicOps.VcoModel.Activities.InvokeVcoWorkflow.Execute(CodeActivityContext context)

   at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)

   at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

[UTC:2014-07-17 12:47:10 Local:2014-07-17 07:47:10] [Error]: VcoWorkflow 'WFStubBuildingMachine' (https://xxx:8281/vco/api/workflows/3060d63b-bfc9-44d8-8806-70988c107787/executions/8a0c14c64740d9540... Failed after 00:00:20.0833246, Invalid Application Code, please enter an application code. (Workflow:-Test-Naming / Scripting (item4)#7)

[UTC:2014-07-17 12:47:10 Local:2014-07-17 07:47:10] [Error]: Error executing vCenter Orchestrator workflow: Invalid Application Code, please enter an application code. (Workflow:-Test-Naming / Scripting (item4)#7)[UTC:2014-07-17 12:47:11 Local:2014-07-17 07:47:11] [Error]: ID: f47f8783-893c-4cd5-b318-b804765c01b3 Workflow 'WFStubBuildingMachine' has failed unexpectedly.

0 Kudos
3 Replies
DLally
Enthusiast
Enthusiast

I just tested with an older script before this update and now it looks like vCAC might not be passing any variables through to vCO now.

0 Kudos
DLally
Enthusiast
Enthusiast

bump, updated with some logs as well.  I've tried searching some of the errors and can't find anything. 

0 Kudos
GrantOrchardVMw
Commander
Commander

Ok, question - why are you applying the workflow at Building Machine (WFStubBuildingMachine) instead of Machine Provisioned?

Grant

Grant http://grantorchard.com
0 Kudos