Highlighted
Enthusiast
Enthusiast

VM blueprint disregarding "hostname" custom property

Jump to solution

Hey all - have a new 7.4.0 HA environment setup for testing.  I have a blueprint setup with a custom property "Hostname" and fill it out during the request... yet the VM is still deployed in vCenter with the machine prefix info.  I can't figure out why it's ignoring this.  Any thoughts?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Immortal
Immortal

"hostname" must be all lowercase. These properties are case sensitive.

View solution in original post

0 Kudos
7 Replies
Highlighted
VMware Employee
VMware Employee

Just wanted to double check, where have you set this property? on the blueprint or on the machine object in the blueprint?

It needs to be set on the machine. I have many blueprints setup like this and works as expected.

Cheers

________________________________________ Blog: http://virtualiseme.net.au VCDX #201 Author of Mastering vRealize Operations Manager
0 Kudos
Highlighted
Enthusiast
Enthusiast

Yep on the machine objective.  I have a non HA lab with the same setting and it works fine.  This one keeps naming it the prefix it's frustrating.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Any further ideas on this one?  It's really odd - I can't figure out why it would be doing this.

0 Kudos
Highlighted
Immortal
Immortal

Do you have this custom property set at the machine object level? How exactly are you spelling it?

0 Kudos
Highlighted
Enthusiast
Enthusiast

Sorry for delayed reply.  Here's how I have it on the machine blueprint item:

pastedImage_0.png

0 Kudos
Highlighted
Immortal
Immortal

"hostname" must be all lowercase. These properties are case sensitive.

View solution in original post

0 Kudos
Highlighted
Enthusiast
Enthusiast

LOL wow that's embarrassing.  To my defense, though, it works in my other setup!

pastedImage_0.png

Changing it to lowercase in the new HA environment works now... but not sure why it worked previously with capitalization

0 Kudos