CHJamey
Contributor
Contributor

There is no Network Profile in dropdown

Jump to solution

vcac 6.0.1

Hello.  I have created a network profile and assigned an ip range to it.  I am now trying to choose the network profile within the Reservation and it is not showing.  I select the network in the network tab and then click the drop down and there is nothing there.  What am I missing here?

Thanks,

Jamey

0 Kudos
1 Solution

Accepted Solutions
awjudge
Hot Shot
Hot Shot

What type of network profile have you created? I think if it's anything other than External, it won't come up unless you have VXLAN configured.

View solution in original post

0 Kudos
5 Replies
awjudge
Hot Shot
Hot Shot

What type of network profile have you created? I think if it's anything other than External, it won't come up unless you have VXLAN configured.

0 Kudos
GrantOrchardVMw
Commander
Commander

That's correct. You can't use NAT, Routed or Private profiles unless have have NSX/vCNS integration configured.

Grant

Grant http://grantorchard.com
CHJamey
Contributor
Contributor

Thanks to the both of you for answering.  It was indeed the type of profile I created.  It was a Private profile.  I created an External profile and was able to select it just fine.

This leads me to my next question.  What is the best way to use static IPs for vcac deployed VMs?  We use an IPAM software.

I am trying some different ways right now but would like to know what other people are doing.

Thanks,

Jamey

0 Kudos
GrantOrchardVMw
Commander
Commander

Which IPAM solution are you using? Two possible ways to do this:

1. Use vCO to request an IP during the BuildingMachine state; or

2. Grab a block of IPs from IPAM and allocate them to "vCAC Workoads" and then allow the Network Profiles to handle the allocation.

Grant

Grant http://grantorchard.com
0 Kudos
CHJamey
Contributor
Contributor

We are using Proteus. 

I created a a couple IP reservations in Proteus and set up the IPs in a network profile.  I then was able to deploy a VM successfully using the network profile.  It received the IP just fine but the issue is there is no forward DNS A record created for the VM.  But, there is a reverse DNS record created.  The other part of this will be decommissioning the DNS record once the VM is destroyed. 

Thanks,

Jamey

0 Kudos