kdbinger
Enthusiast
Enthusiast

Moving provisioned VM to specific Active Directory OU

Looking for some assistance on moving a vCAC / vRA provisioned VM into a specific OU.  We use a customization specification that joins the VM to the domain and I have the correct custom properties applied to the blueprint that should move it to the correct OU; however, the VM's do not get relocated.  Am I doing something wrong?

Here's what I have for custom properties:

Infrastructure.Admin.ADPassword    Value: myverysecurepassword

Infrastructure.Admin.ADUser     Value: mydomain\myelevateduseracct

Infrastructure.Admin.MachineObjectOU   Value: OU=Workstations,DC=mydomain,DC=com


Any help is appreciated!

0 Kudos
3 Replies
keeleral
Enthusiast
Enthusiast

I'm not sure if you use vRO during my provisioning process but i built a workflow that creates the object in the specific OU i want it in.  Then when the vm is built and the customization spec joins it to the domain it finds the object and links up with it.  That process has worked well for us, however i have not used the custom properties to do it so Im not much help there

kdbinger
Enthusiast
Enthusiast

Thank you keeleral - I suspect that is what we will end up doing; however, it seemed like the functionality was native in based on the custom properties I used - but perhaps I have a misunderstanding of how those particular custom properties work.

So did you simply modify the workflow stub to call the Add Object to AD?  I assume it somehow pulls the VM name and then passes that to the workflow?  Can you share your workflow and or step out your process?

0 Kudos
kdbinger
Enthusiast
Enthusiast

Curious if you ended up using the aforementioned workflow or if you were able to resolve the native AD Plug-in that you tried?

0 Kudos