Highlighted
Enthusiast
Enthusiast

Linux Guest Agent not working properly

Attempting to build out my first linux template for vCAC but it doesn't seem to be running any scripts.  The guest agent constantly puts out the below error message.

I'm trying to run a basic file that adds a user to the sudoers file, it works fine when I run it manually using the same command that vCAC is suppose to pass.  It will not work through vCAC though.  I assume something is wrong with my agent but curious if anyone else has seen this before.

2015-08-05 18:14:31 Application.MachineQuery: [Information] uuid = 4226c8d2-3c98-8304-4a8d-03be821fb47e

2015-08-05 18:14:31 Application: [Debug] Using the network enabled proxy ...

2015-08-05 18:14:31 Application: [Debug] The vCAC endpoint is https://HOSTNAME:443/VMPS2.

2015-08-05 18:14:31 Application: [Debug] The AXIS2C directory is axis2/.

2015-08-05 18:14:31 Application: [Debug] Requesting work for agent ID d2c82642-983c-0483-4a8d-03be821fb47e.

2015-08-05 18:14:31 Application: [Debug] Fetching a work item ...

2015-08-05 18:14:31 Application.Proxy: [Debug]

2015-08-05 18:14:31 Application.Proxy: [Debug] No workitem currently available

I've double checked my hostname as well, the settings for the agent look to be correct.

0 Kudos
4 Replies
Highlighted
Immortal
Immortal

The value on the hostname in https://HOSTNAME:443/VMPS2 needs to be the manager service vRA server - this server runs the VMPS2 URL. Try to hit that url to make sure you are registering the linux gugent agent to the correct vRA server in your template. Also, the guest agent only works with clone and link clones. This article should help How to create a vCAC 6 Linux Guest Agent Template | VMtoCloud.com

Here you have "The vCAC endpoint is https://HOSTNAME:443/VMPS2https://HOSTNAME:443/VMPS2.". What is HOSTNAME? It looks like you haven't registered the gugent agent with the vRA VMPS2 server, the manager service.

Oli

0 Kudos
Highlighted
Enthusiast
Enthusiast

Sorry for the confusion, I just replaced the FQDN of my server with the word HOSTNAME.  I understand that this needs to be the fqdn of the vCAC (only on version 6.1) IaaS server.  This is the way it is setup.  Also I am using this with a clone action.

I have found that article many times in my google searching for a solution. So far VMware tech support has not been of any help either.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Sutter, I am also running into similar issue. Were you able to get this working?

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi Sutter,

I got this working. I was running into the same issue. Here are steps to resolve the issue -

1. Download the certificate using Firefox and save it as say cert.crt

2. Convert the Certificate to PEM file using the command -

   # cd /usr/share/gugent

   # cp /home/pankaj/cert.crt .

   #openssl x509 -in cert.crt -out cert.pem -outform PEM

   #cp cert.pem asix2/

3. Now Install the Guest agent

   #./installgugent w2012vm.qa.com:444 ssl

My Windows Iaas VM is w2012vm

4. Make sure to have the permissions set to 777 on your script, in my case

#cd /

#chmod 777 print.sh

5. Also you need to install the Following changes on your Windows Iaas. Make sure to reboot SSO, VRA and Iaas after this

a) Disable TLS 1.2

https://support.microsoft.com/en-us/kb/2973337Windows_11.png

b) Install the Following patch on Windows Iaas

https://support.microsoft.com/en-us/kb/245030

Thanks,

Pankaj

0 Kudos