mohab_samy
Contributor
Contributor

Installation 7.4 Failed

Installation Failed for vRA 7.4 in the Web configuration stage, I revert IaaS server snapshot but when I tried to retry the installation again the faced the following error related to Certificates:

Message: Command execution failed. Error: An item with the same key has already been added.

Description:

System.ArgumentException: An item with the same key has already been added.

   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)

   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)

   at VMware.IaaS.Management.Agent.CommandFrameworkService.d__10.MoveNext()

Output:

{

    "executionOutput": "Installing certificate...\r\nCertificate installed successfully.\r\nExecution time:00:00.032\r\n"

  }

8 Replies
daphnissov
Immortal
Immortal

What type of architecture are you attempting to deploy here? If you can, go back through the installation wizard and take screenshots of every page that shows the values you're providing. I know this sounds tedious, but it's the best way to get an understanding of your environment without going back and forth for dozens of posts.

0 Kudos
mohab_samy
Contributor
Contributor

I am using Enterprise Deployment, 3 Nodes for vRA Appliances, 2 Nodes for IaaS (Web, Manger), 2 Nodes for Agent and 2 Nodes for DEM Worker,

After retrying many times it installed pass some steps till creating the DB and no failed in WEB configuration

I will post the screenshots shortly

0 Kudos
mohab_samy
Contributor
Contributor

Sorry it is vRA 7.5

0 Kudos
gradinka
VMware Employee
VMware Employee

do you have a case opened with support?

I think I've seen one on somebody having similar issue so checking is it the same instance or there is a trend

0 Kudos
daphnissov
Immortal
Immortal

Still waiting on those screenshots....

0 Kudos
mohab_samy
Contributor
Contributor

sorry it is a production setup and under NDA for that i can't share the screenshot

0 Kudos
wakeman811
Enthusiast
Enthusiast

* Initial installation of vRealize Automation 7.x fails with a "Validation failed" status for the "Retry All IaaS" operation (59812)

https://kb.vmware.com/s/article/59812

Workaround

  1. SSH into the vRealize Automation appliance in which is the master postgres node.
    1. su postgres
    2. psql
    3. \c vcac
  2. Run the following SQL update statement on the embedded vPostgres database:
UPDATE cluster_commands set output='' where type like '%install%';
  1. Re-initiate the "Retry All IaaS" operation again.
Note: If the SQL statement is executed before the installation is started, "Retry All IaaS" does not fail.

AScera
Enthusiast
Enthusiast

Thanks, following these steps, I was able to advance in my installation.

More information:   vRealize Automation 7.5 Release Notes  &  https://kb.vmware.com/s/article/59812

Best regards, RA

pastedImage_2.png