ZenithVM
Enthusiast
Enthusiast

Iaas Installtion Failure

Jump to solution

While installtion of IAAS  in a LB F5 setup I have encountered following error :

Info : 2015-04-09 06 01 42 327 PM : System.Data.Services.Client.DataServiceTransportException: Unable to connect to the remote server ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 192.168.18.13:443






0 Kudos
1 Solution

Accepted Solutions
ZenithVM
Enthusiast
Enthusiast

Issue resolved finally :

client and server certificates in the LB both should be available and same and the signing rooCA certificate should also be available with the LB

View solution in original post

0 Kudos
7 Replies
CoolRam
Expert
Expert

If you are using Loadbancer then go to the loadbalancer  and check the virtual IP and its Node should showing Connected (Green Icon).  Its Seems like IaaS is not able to reach to DB using loadbalancer.

If you find any answer useful. please mark the answer as correct or helpful.
mteofrio
VMware Employee
VMware Employee

I have run into the same issues. Check the following:

-Load Balancer Configuration particularly the VIP for the IaaS Web and your cert config.

-The certificates that are being used. Make sure you have the FQDN and Host name are in the SAN of the cert. Check the Cert Chain.

-DisableLoopBackCheck under LSA in the Registry of the IaaS server.

Thanks,

Mike Teofrio

0 Kudos
sree_30
VMware Employee
VMware Employee

Hello, Could you try these steps to validate if you LB is working fine,

1) IIS is already installed on the server

2) Bind port 443 to default website selecting the certificate

3) Make sure that only one active node is selected in the load balancer

4) try hitting the LB IAAS web IP to check if the LB is correctly redirecting the connection on port 443 to your IAAS web

0 Kudos
SkyCoop
VMware Employee
VMware Employee

Did you disable the loopback on the IaaS server to include the VIP name for the tier you are installing?

0 Kudos
pizzle85
Expert
Expert

here's what i had to do:

  1. set a monitor on the LB pool that sets the servers to always be up
  2. manually disable the second pool member
  3. install IaaS web on the primary server
  4. install IaaS web on the secondary server
  5. enable the second pool member
  6. set the monitor back to the correct one
0 Kudos
ZenithVM
Enthusiast
Enthusiast

Issue resolved finally :

client and server certificates in the LB both should be available and same and the signing rooCA certificate should also be available with the LB

View solution in original post

0 Kudos
TonyKhan
Enthusiast
Enthusiast

Hi,

I had a similar error message, but it was not related to SSL.  My issue was resolved by disabling the secondary web in LB and creating a host file entry on the primary web server (Web + Model Manager). So basically, I pointed the web LB URL to a local host and that did the trick.  After the install, i removed the host entry and then enabled secondary web in LB. Smiley Happy

Info : 2015-06-29 11 36 49 932 AM :  System.Data.Services.Client.DataServiceTransportException: Unable to connect to the remote server ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond xxx.xxx.x.xxx:443

Cheers,

Tony

0 Kudos