Contributor
Contributor

Google Chrome updates breaks vRA deployments

More of a warning than discussion, a few people within my team updated chrome to the latest version, since then the deployment button is missing when deploying a machine in vRA

29 Replies
Immortal
Immortal

Care to provide some more information? What version of vRA? What version (exact) of Chrome?

Enthusiast
Enthusiast

Same here.  Thought it was IAAS choking.  Rebooted the environment a couple of times.  No luck.  The Submit and Cancel buttons seem to render off page.  This is for standard and custom forms.  I had a Chrome install that didn't auto update yet and the buttons rendered fine.  Then I looked at the version and Chrome updated.  Then the buttons disappeared.

Confirmed on a fresh deployment of Win 10 and new installation of Chrome.

This worked fine yesterday afternoon and then stopped working last night.  Works fine in Firefox!

Chrome: 75.0.3770.80

vRA: 7.5.0 Build 10053500

Windows 7 and 10 with current patches.

Immortal
Immortal

I just tested with that exact same version of Chrome on a vRA 7.4 installation with both standard and custom forms and I don't see the issue. Guessing it's vRA 7.5+.

Contributor
Contributor

vRA 7.6 chrome 75.0

Enthusiast
Enthusiast

Well there goes my hope of it being fixed in 7.6.  Smiley Sad

Enthusiast
Enthusiast

vRA Version: 7.5.0 (Build: 10053500)

Chrome Version 74.0.3729.169 (Official Build) (64-bit) - buttons present

Chrome Version 75.0.3770.80 (Official Build) (64-bit) - buttons missing

Ugh. SR opened.

Virtuoso
Virtuoso

I can confirm in my environment vRA 7.5 and Chrome 7.5 on my Mac has this issue.  I can tab to the buttons though so for folks experiencing this you can probably work around the issue while the bug gets squashed.

Contributor
Contributor

Same problem here with my PROD instance of vRA at 7.5.0.458 Build 10053539 and tested in my DEV instance at 7.6.0.317 Build 13027280

Chrome 74.x working, Chrome 75.x missing buttons on forms.

Hopefully hotfix coming soon.

0 Kudos
Contributor
Contributor

I  am having the same issue using Chrome 75.0.3770.80 (Official Build) (64-bit) to access vRA 7.6.0 (Build: 13027133). The Submit and Cancel buttons are missing from all catalog forms.
I have been able to replicate the issue in more than one environment. Luckily, Firefox 67.0.2 (64-bit) is working without issue.

0 Kudos
Contributor
Contributor

it looks to be part of a "Scroll bar" issue. The page isn't recognizing the lower bound of the page or something. If I open the developer tools and do a  find for the "button-bar" element and highlight it with my mouse/select it the page snaps down to show the buttons. This obscures the top of the page up past the page bounds but does not give a scrollbar on the right of the page to move up and down.

<div _ngcontent-c0="" class="button-bar">

                  <button _ngcontent-c0="" class="btn btn-sm btn-primary catalog-request-btn" id="catalog-request-submit">Submit</button>

                  <button _ngcontent-c0="" class="btn btn-sm btn-outline catalog-request-btn" id="catalog-request-cancel">Cancel</button>

              </div>

0 Kudos
Enthusiast
Enthusiast

My workaround when this issue happens is to use TAB key until the Submit/Cancel buttons appear.

Enthusiast
Enthusiast

Same Problem here:

Chrome: 75.0.3770.80

vRA 7.5 HF7

Any news from open cases? I will open one.

0 Kudos
Contributor
Contributor

Please do open cases. I opened a case and the forwarded my information along. They are aware of the issue and and have an open escalation to there development team that is being worked on, but I imagine more information and/or more reports = higher priority.

Contributor
Contributor

nice,  i love the simple workarounds, I'm doing the same

0 Kudos
Enthusiast
Enthusiast

I had opened an SR and referenced this thread.  Support has told me that this has been identified and engineering is working on it.  Hopefully, they have a fix soon.

0 Kudos
Contributor
Contributor

We also experience this issue since the Chrome 75 update on our vRA 7.5 HF6 installation. Opened a SR.

0 Kudos
Enthusiast
Enthusiast

Just heard back from support. The fix is planned for 7.6.1 and will be backported to vRA 7.5. So in our case (vRA 7.5) the fix should be implemented in one of  2 next HF releases. So hopefully we get it in July.

Enthusiast
Enthusiast

We also got the bug.

The button is actual there, but just not shown on the screen.

If you use TAB and you "tab" you to it, and it will be visible.

0 Kudos
Contributor
Contributor

The issue is set to be resolved in cumulative update releases for vRealize Automation 7.5 & 7.6.

****

Deployment forms are missing the Submit, Next and Cancel buttons when using Chrome 75 (70879)

***

https://kb.vmware.com/s/article/60310