sivakumarss
Enthusiast
Enthusiast

Getting 405 Method not found error when tying to update VCAC through VCO workflows

Hello all.

I am trying to run the workflow 'Update a VCAC model entity' from within another workflow.

I am able to succesfully read the required entity(s) from 'Read a VCAC entity by custom filter', then choose the appropriate entity, pass it to the 'Update' workflow.

But when executing the last part, I am getting the '405 Method not allowed error' from the IIS (the Windows machine running IAAS service).

Even the standard workflow 'update blueprint property' also fails with same error.

Is there some configuraiton issue with IIS server?

Thanks

- Siva

Tags (3)
0 Kudos
6 Replies
GrantOrchardVMw
Commander
Commander

That implies that you're using the wrong method when interacting with the API. Perhaps a POST instead of a PUT or something similar?

Grant

Grant http://grantorchard.com
0 Kudos
sivakumarss
Enthusiast
Enthusiast

Grant.

Thanks for the suggestion.

But this is a standard VCO workflow that I am running. I am not developing anything new.

The 'create', 'read' workflows are running fine, but not the 'update' workflow.

Suspect some setting in IIS to be the issue.

0 Kudos
sivakumarss
Enthusiast
Enthusiast

Found the following to fix this issue.

In the IIS manager page, go to /Repository page.

In the Mapping Handlers, select WebDAV. Edit and add 'POST' to the list of verbs.

This seem to work so far.

0 Kudos
Commens
Contributor
Contributor

Updated to 6.2 and started getting this same 405 error when using hte Update a vCAC model entity similar to the original post.  I tried the same verb as mentioned as a fix, but that doesn't work for me.  Still getting 405 method not allowed.

0 Kudos
DLally
Enthusiast
Enthusiast

I'm getting this error still, previously had it before the orchestrator 6.0 appliance was released.  I was told to wait for that, it'd fix my issue.  Now I'm on the 6.0.2 appliance and it's giving me this same error.

I've added Post to the repository mapping handlers and still not change.

Any ideas?

0 Kudos
FerrerDeCouto
Commander
Commander

Hi,

I had the same issue and after remove the IIS WebDAV module from my IaaS server it worked. Also you need to remove any trace of WebDAV in Handler Mappings.

Regards,

Jose

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.