jstander
Enthusiast
Enthusiast

Extensibility consumer error(10030)

Since my upgrade from vRA 7.2 to 7.4 and external vRO upgrade from 7.2 to 7.4 I have been getting the following error when trying to deploy a blueprint.

) Error in state VMPSMasterWorkflow32.BuildingMachine phase PRE event (queue = 158b52e8-fcf0-423a-b9e2-4ab73b2561b7): Extensibility consumer error(10030) - {com.vmware.csp.core.designer.service@event.subscription.workflow.execution.timeout} and atlv-ldevapp12: sendEBSMessage4(workflow=b76353e4-a224-401d-b9c9-41bea2541cbd) Error in state VMPSMasterWorkflow32.Requested phase PRE event (queue = f2a6ab63-a780-42b0-80be-c79151558e45): Extensibility consumer error(10030) - {com.vmware.csp.core.designer.service@event.subscription.workflow.execution.timeout}.

Has anyone else come across a similar error?

0 Kudos
1 Reply
jstander
Enthusiast
Enthusiast

This problem only started happening since I upgraded my vRO external cluster from 7.2 to 7.4.

I have been having a lot of problems ever since the upgrade with vRO.

1st node was upgraded from 7.2 to 7.4

2nd node is a newly deployed vRO 7.4 appliance, which took on the same IP address and Hostname or old 2nd, and was added to the cluster (followed the upgrade procedure provided by VMware)

If I set both my vRO nodes as active in the LB, then I get an error in VRA's VRO server configuration saying "unable to connect to port", however when I set the weight or disable the 2nd node I get a successful connection.

Screen Shot 2018-05-25 at 5.04.10 PM.png

Nothing in vRO control center or in logs was indicating that there is something wrong with the cluster, but after I removed the 2nd node from the cluster it resolved my external Orchestrator server connection as well as the timeouts I was getting when trying to deploy blueprints.

0 Kudos