Enthusiast
Enthusiast

Custom Form bluerpint fails

We tried creating a custom form BP using this blog - Customizing request forms using the new Custom Forms - VMware Cloud Management . The Blueprint fails with following error however workflow in vCO ran successfully. I have checked the user has full rights to run the workflow.

"The following component requests failed: SetupUser. General error occurred while attempting to execute workflow with id 'e9d9663c-3dcd-4d5a-ad22-d3d82dc5c125', for WorkflowRunState 'e9f143c9-28d5-4842-8ee2-b2cd9324113e'. Error 'Unable to find workflow execution for this request. Maybe it was deleted on vCO side or the user don't have sufficient rights.'. Cause 'Unable to find workflow execution for this request. Maybe it was deleted on vCO side or the user don't have sufficient rights.'. Check the logs for more details."

pastedImage_1.png

pastedImage_2.png

0 Kudos
8 Replies
Enthusiast
Enthusiast

The last tried blueprint Request ID is 10990. Attached vcac and vco log. Any pointer to check further would be helpful.

0 Kudos
Immortal
Immortal

Show screenshots that detail your vRO configuration inside the vRA portal, please. This is an internal (embedded) vRO, yes?

0 Kudos
Enthusiast
Enthusiast

Yes, this is an internal vRO.

pastedImage_0.png

0 Kudos
Enthusiast
Enthusiast

Bumping up to see if somebody can help me out here

0 Kudos
Enthusiast
Enthusiast

Any help would be appreciated.

0 Kudos
Contributor
Contributor

Have you register plugins inside of orchestrator?

Take a look: https://docs.vmware.com/en/vRealize-Automation/7.2/using-vra-plugin-72-guide.pdf

0 Kudos
Enthusiast
Enthusiast

I am using embedded vRO. All available plugin should be there by default. Are you referring to any particular plugin?

0 Kudos
Contributor
Contributor

I faced same issue:

General error occurred while attempting to execute workflow with id 'f3024fda-572f-452e-b896-d44caaa5691b', for WorkflowRunState 'afc5513e-287a-4b0f-b1c3-f2e7649735b8'. Error '400 '. Cause 'Cannot execute workflowId 'f3024fda-572f-452e-b896-d44caaa5691b' for Workflow run request 'afc5513e-287a-4b0f-b1c3-f2e7649735b8'. Error details: 400 '. Check the logs for more details.

I found the answer in "server.log" file to my problem:

2020-01-03 15:32:27.935+0100 [https-jsse-nio-0.0.0.0-8281-exec-6] ERROR {} [BaseController] Error invoking REST [unknown]

java.lang.IllegalArgumentException: 2 error(s) found: [ { Short notation - This field is required. }  { CRQ Number - Non matching regexp } ]

        at com.vmware.o11n.web.presentation.service.PresentationServiceImpl.validateParameters(PresentationServiceImpl.java:369)

These real errors aren't showed in vRA console.

BR,

JI

0 Kudos