pengchen4
Contributor
Contributor

Can not request a Catalog Item from vRA7

Jump to solution

Hi experts,

I have several catalog items on my vRA7, when I request any of them, the status of the requests are always stay on "In progress".  I checked the log on vRA and found an error log said below message.

<!DOCTYPE html>

<html>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

<meta content="text/css" http-equiv="content-style-type">

<meta name="author" content="VMware, Inc.">

<meta http-equiv="Pragma" content="no-cache">

<meta http-equiv="Cache-Control" content="no-cache,no-store">

<meta http-equiv="expires" content="Tue, 20 Aug 1996 14:25:27 GMT">

<title>Identity Manager</title>

<link rel="shortcut icon" href="https://communities.vmware.com/img/favicon.ico" type="image/x-icon">

<link rel="stylesheet" type="text/css" href="https://communities.vmware.com/error/css/base.css"/>

</head>

<body class="horizon one-col">

<div class="admin-header">

<div class="admin-header-inner">

<div class="admin-header-org">Identity Manager</div> </div> </div>

<div class="content clearfix"> <div class="content-inner">

<div class="error-message clearfix">

<div class="float-l ico-16 ico-error"></div>

<div class="text"> The page you were looking for is not available. You may need to contact your administrator with this error: 404 Page Not Found. </div>

</div> </div> </div>

<div class="footer clear"> <div class="footer-inner">

<div class="footer-text"> Identity Manager 2.5.1.0 Build 3614368. Copyright © 2013-2015 VMware, Inc. All rights reserved. This product is protected by copyright and intellectual property laws in the United States and other countries as well as by international treaties. VMware products are covered by one or more patents listed at

<a href="http://www.vmware.com/go/patents">http://www.vmware.com/go/patents</a>.

</div> </div> </div> </body>

</html>


Does anyone met the same issue? any suggest will be appreciated.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
rmav01
Enthusiast
Enthusiast

Do you see any actions that the service is supposed to be doing such as cloning a machine on the vCenter occurring? Can you see any reservations take place like a static IP assignment on a network profile? Trying to determine where it fails out in the process should be able to help you better in troubleshooting it. As an example, on my instance I would have requests get stuck as "in progress" after it cloned the machine and attempted to run an attached software component. I figured out that I needed to install the bootstrap agent on the template I was using in order to actually apply the script baked into the component or it would stick.

View solution in original post

0 Kudos
5 Replies
GrantOrchardVMw
Commander
Commander

I'd suggest that you login to the Windows box where your Manager Service (vCloud Automation Center Service) is meant to be running and check if it has stopped.

Grant http://grantorchard.com
0 Kudos
pengchen4
Contributor
Contributor

Thank your for your reply! Do you mean the IAAS server? I would say it has already started and I can see Infrastructure things from vRA. So I believe there's should be other special reason cause the issue.

0 Kudos
rmav01
Enthusiast
Enthusiast

Do you see any actions that the service is supposed to be doing such as cloning a machine on the vCenter occurring? Can you see any reservations take place like a static IP assignment on a network profile? Trying to determine where it fails out in the process should be able to help you better in troubleshooting it. As an example, on my instance I would have requests get stuck as "in progress" after it cloned the machine and attempted to run an attached software component. I figured out that I needed to install the bootstrap agent on the template I was using in order to actually apply the script baked into the component or it would stick.

View solution in original post

0 Kudos
GrantOrchardVMw
Commander
Commander

It's a service on the IaaS server yes. The pages you see under the Infrastructure tab are served up by a different service, so don't assume that because the pages are there, all is well.

Grant http://grantorchard.com
0 Kudos
pengchen4
Contributor
Contributor

Thank you for you reminding! I think I got the reason is that my vRO endpoints on vRA data collection failed. So a request of catalog item from vRA always stay on step of finding back-end workflow on vRO, and status will be on in progress all the time.

0 Kudos