deepakjangra023
Contributor
Contributor

How to get Vms moved to another host on reaching the resources utilization of host- upto 80 %


I have DRS cluster and want that my VMs moves if the host utilization reaches upto 80%. Please suggest..

0 Kudos
6 Replies
deepakjangra023
Contributor
Contributor

is there anyone who can support me on above query???

0 Kudos
weinstein5
Immortal
Immortal

Welcome to the Community - Keep in mind as the purpose is to insure the VMs are receiving sufficient resources so as long as the VMs are receibing suffivient resources the VMs will not vmotion even if you host is at 90% utlization and the other hosts are at 0% utilization - you might try setting migration threshold of the clister to aggressive it might move some of the vMs but no gaurantee

Also I have moved this question to a more appropiriate forum

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
deepakjangra023
Contributor
Contributor

Thanks, Well we have already set automation level to aggressive mode but still VMs are not migrating from "A" host to B host. Once CPU utilization is 90% & above then VMs are migrating to B host.

Our requirment, we have to set 80% CPU & Memory threshold in host level (A) so that VMs will be migrate from A host to B host. Pleas suggest.

0 Kudos
deepakjangra023
Contributor
Contributor

i required to solve this issue on urgent basis. Please help..

0 Kudos
weinstein5
Immortal
Immortal

It looks like your hosts are able to satisfy the VM resource requirements up to 90% utilization - Other than manually migrating the VMs when you hosts hits 80% utilization as long as the VM is receiving sufficient reources there is no automated way to migrate the VMs

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
0 Kudos
deepakjangra023
Contributor
Contributor

Hello weinstein,

Ii agree with you but you know what exactly happening in my scenario, host's resource utilization is going upto 95% and then host enters in "not responding" mode due to which vMotion doesn't happening. could you please suggest what i should do in this case.

0 Kudos