mafboston2011
Contributor
Contributor

trying to setup vcloud usage applaince stuck

Trying to follow the doc, this does not work for me:

5. Enter a new password and reenter to the same password to confirm.
The password is changed.
6. The webapp password must be initialized before it can be used. Run the command

 /opt/vmware/cloudusagemetering/scripts/webpass.sh
with no arguments for directions. Precede the command with a space, so the command, along with password, won't be saved in the shell history. The command may take some time to run. Execute the arguments for the role, service provider <s> or aggregator <a>, you wish to run as.

7. Type Exit to return to the virtual machine console and reset your time zone.
8. On the virtual machine console, navigate to Set Timezone and press Enter.
9. Select your time zone and press Enter.
10. To reflect the changed time zone you must restart the tomcat service.
11. Navigate to the Login and press Enter. Enter credentials and at the prompt, Type service tomcat restart and press Enter to restart the Tomcat service.
Upgrading vCloud Usage Meter
You can upgrade your existing vCloud Usage Meter setup to vCloud Usage Meter 2.2 from

Step 6 makes no sense to me, the command seems incomplete. Are there better instructions somewhere? Error message is in the attached document.


Thanks,

0 Kudos
9 Replies
dbriccetti
Hot Shot
Hot Shot

We regret that the webpass.sh command isn’t easier to use, and that it currently always displays three lines of misleading messages.

If you are a service provider, try

...webpass.sh set s xyz

where xyz is the password

0 Kudos
mafboston2011
Contributor
Contributor

Thanks for the response, I had tried that already and I get:

-bash: webpass.sh: command not found.

I've even cd into the dir the webpass.sh lives in and it says that and tried it with ./ ahead of it, nothing works.

My Unix skills are from 1994 so I'm rusty on this Linux stuff.

MAF

0 Kudos
dbriccetti
Hot Shot
Hot Shot

Your ’94 Unix skills should do the job here.

/opt/vmware/cloudusagemetering/scripts/webpass.sh set s abc

where s means service provider and abc is the password

0 Kudos
mafboston2011
Contributor
Contributor

Yeah, I tried that too before, just did it again....getting that same error I posted in the attachment

SLF4j: Failed to load class "org.slf4j.impl.StaticLoggerBinder".....etc.

0 Kudos
dbriccetti
Hot Shot
Hot Shot

You can ignore those three lines of apparent errors. If you see nothing else, then the command worked.

0 Kudos
mafboston2011
Contributor
Contributor

Ok, then the next step in the doc talks about doing all this stuff in the UI, it does not mention the URL, I can guess it is not on 80 or 443....plus we just set the password for the webuser, what is the username?

Thanks,

Miles

0 Kudos
dbriccetti
Hot Shot
Hot Shot

https://<host>:8443/um/

There are no users. You’ll see what to do.

0 Kudos
matt232
Contributor
Contributor

Entirely redundant but the KB article on the issue appeared a day or two ago.

http://kb.vmware.com/selfservice/search.do?cmd=displayKC&docType=kc&externalId=2011334

0 Kudos
mafboston2011
Contributor
Contributor

Thanks, you have been helpful clarifying this vauge documentation (and that is being kind).

If you type set timezone from the console prompt nothing happens, is it supposed to give list of timezones?

Also, I don't think DNS was setup when the appliance was installed since I'm having trouble connecting to the FQDN from the Web GUI.

How can I check/set that?

Thanks again....

The next step setting the timezone is also completely unclear:

7. Type Exit to return to the virtual machine console and reset your time zone.
8. On the virtual machine console, navigate to Set Timezone and press Enter.
9. Select your time zone and press Enter.
10. To reflect the changed time zone you must restart the tomcat service.
11. Navigate to the Login and press Enter. Enter credentials and at the prompt, Type service tomcat restart and press Enter to restart the Tomcat service.
Upgrading vCloud Usage Meter
You can upgrade your existing vCloud Usage Meter setup to vCloud Usage Meter 2.2 from vCloud Usage

0 Kudos