rputzler
Contributor
Contributor

Usage Meter 2.1.1 Reporting incorrect

In the Usage Meter version 2.1.1 the Aggregate Billing Report is always showing the same values for both the Total Allocated vRAM and the Total Billed vRAM despite the Detailed billing report showing them to be considerably different.  Is this a bug in the 2.1.1 version?

Labels (1)
0 Kudos
8 Replies
dwhittaker
Contributor
Contributor

I have this issue also, with the earlier 2.1 release in my case. Not yet upgraded to latest dot release.

0 Kudos
admin
Immortal
Immortal

I'm curious, what are you two putting in for memory cap?

0 Kudos
dwhittaker
Contributor
Contributor

24576 (24x1024MB) as per a vCloud Service Provider Bundle guide document provided by VMWare. I can't reference you which document it was as I simply have the pertinent page printed out and stuck above my desk and I'll need to go trolling through my emails to find the correct reference which I currently can't do.

aggbillreporterror.jpg

Message was edited by: dwhittaker - Added picture.

0 Kudos
dwhittaker
Contributor
Contributor

Reading between the lines of your question, is this simply a wording issue? "Allocated" meaning the billed (allocated*50%) or (reserved) amount of vRAM (not the full allocated amount assigned to a VM) and "Billing" meaning the amount that is actually billed assuming you have VMs that hit the cap specified in the report?

If so, that may need to be clarified, given that's a second definition of what allocated is in relation to vRAM reporting from vCloud UM. If not then ignore my rambling in this post.

0 Kudos
rputzler
Contributor
Contributor

I too am using 24576, per the vCloud Service Provider Bundle guide.

0 Kudos
rputzler
Contributor
Contributor

Any news on this?  For service providers to properly report for September this functionality needs to be fixed by the end of the month.

0 Kudos
drechsau1
Contributor
Contributor

I, too, am having issues and have been talking to someone at VMware.

Mine is different though, I am showing 147 GB (though this should be 1554 GB).

0 Kudos
JohnMurrayUK
Contributor
Contributor

According to VMware the report is working but the column headings are not great.

In the Aggregate Billing Report, there is a column called 'Total Allocated vRAM (GB-hour)'.  This value is the aggregate of the 'billing ram' for each VM, not the 'allocated ram'.  Hence the value should be the same as the 'Total Billed vRAM (GB-hour)' value, unless you have VMs that exceed the per-VM Memory Cap (24576MB).

The ‘Total Allocated vRAM (GB-Hour)’ column heading should really read something like ‘Total Billing vRAM (Uncapped GB-Hour)’ and the’Total Billed vRAM (GB-Hour)’ should really read something like ‘Total Billed vRAM (Capped GB-Hour)’.

0 Kudos