hectorivand
Contributor
Contributor

Upgraded to UM3.0 error: InvocationTargetException, javax.crypto.IllegalBlockSizeException (email password was not first cleared)

Hi, we have a several customers who update to Usage Meter 3.0 and have error when try to log in to the portal.

Attach logs

Any advices?

Message was edited by: dbriccetti: Changed title for better searching on this problem

Tags (1)
0 Kudos
4 Replies
admin
Immortal
Immortal

I've sent a note back to our development group to look at this post and the logs.

You upgraded from 2.3.2 and cleared out your email password correct?  I'm assuming so since I didnt see any ciper errors in the log set.

0 Kudos
dbriccetti
Hot Shot
Hot Shot

Hi. The clue here is this:

Message: javax.crypto.IllegalBlockSizeException: Input length must be multiple of 8 when decrypting with padded cipher

We don’t do a very good job when users skip the step of removing their email server password and saving, as described in the release notes:

Reenter Outgoing Email Server Password

If you have configured an outgoing email server and it requires a password, enter the password again and push Save. Usage Meter 3.0 changes the way the password is stored in the database, and we are unable to convert the existing value.

Could that be the situation here?

Dave Briccetti

Lead developer, Usage Meter

0 Kudos
dbriccetti
Hot Shot
Hot Shot

This should fix you right up:

Log in as root and do this:

sudo -u postgres psql usage_meter_db
update "EmailServer" set password = '';
hectorivand
Contributor
Contributor

first to all, thank you for response.

I Will send this data to my customers (are services providers) to check if doing this the problem dissapear, I will stay in touch with you, to let you know about.

Sorry my bad english.

Thanks again.

Nacho

0 Kudos