bobnv
Contributor
Contributor

Fault Tolerance enabled VMs appear to be counted twice in my monthly usage report

Hello,

I have a vCloud Usage Meter running 2.3.0.0 Build 632601 and it appears that both the live and shadow instances are being collected and our monthly reports are highly inflated.

Can anyone confirm whether FT VMs should be charged twice or not? I have the following from the release notes of 2.2:

"Handle Virtual Machines Protected by FT: Shadow virtual machiness for fault tolerance are not included in usage reporting."

If my usage server is not behaving correctly, please could someone direct me to the best way to raise a support query? (I know know whether to contact licensing or technical support. There don't seem to be any categories for VSPP on the new support case pages I've seen.)

Regards,

Bob McChesney

Labels (1)
0 Kudos
4 Replies
IamTHEvilONE
Immortal
Immortal

Bob,

I would say that this is expected in 2.3.x.

When you use VMware FT, both the original VM and the FT VM are considered powered on and consuming CPU/vRAM/Disk/Network.

I'll see if I can get someone to confirm this internally.

Best Regards,

Jon Hemming

0 Kudos
bobnv
Contributor
Contributor

Hello,

Thanks. I've also raised a support request. Not had any response since 28th May.

It seems not to be well known whether FT should be charged/counted once or twice and I can't find anything in any agreement about it. It would be good to have a definitive answer.

Regards,

Bob McChesney

0 Kudos
bobnv
Contributor
Contributor

Hello,

I received the following response to my support query this morning:

"Your issue with counting VMs twice with fault  tolerance enabled ... is a bug which is broken in 2.3, it will be fixed in 2.3.2.1 patch."

I have enquired when 2.3.2.1 will be released and will updated this thread when I have a response.

Regards,

Bob McChesney

0 Kudos
bobnv
Contributor
Contributor

Hello,

Today I received vCloud Usage Meter 2.3.2.1 Update8 from support. This corrected my issue and now Fault Tolerant machines are being recorded once. The historical data has also been corrected.

Below I will detail the fix, but you should probably speak to support about the issue before executing the following hotfix, since this is pre-release and you shouldn't trust hotfixes from strangers. Refering to support request 12179160805 may improve the response time.

First, you must upgrade your vCloud Usage Meter to version 2.3.2 following the instructions in the release notes. This is available at https://my.vmware.com/group/vmware/get-download?downloadGroup=UMSV2

Next download 2321update8.zip (attached) and transfer it to /tmp on the Usage Meter VM. Perform the following steps to apply the hotfix:

  1. chmod a+r /tmp/2321update8.zip
  2. service tomcat stop
  3. top -u usgmtr
  4. Kill any processes showing, with "k" and enter the Process ID
  5. q to quit
  6. sudo -u usgmtr unzip -q /tmp/2321update8.zip -d /usr/local/apache-tomcat-7.0.14/webapps/um
  7. Answer the prompt to replace all files ("A")
  8. service tomcat start

Thank you to JJ O'Sullivan at VMware Support for resolving this issue for me.

Regards,

Bob McChesney

0 Kudos