PAckermann
Contributor
Contributor

Can't upgrade from 2.3.2 to 3.0

Hi,

I've tried to upgrade from 2.3.2 to 3.0 using  the usage-meter-300-update.zip. When running the updateum-script, I get the following errors:

Updating database
CREATE TABLE
psql:/opt/vmware/cloudusagemetering/database/migrate/232-300.sql:11: ERROR:  could not create unique index "idx93330a92"
DETAIL:  Table contains duplicated values.
psql:/opt/vmware/cloudusagemetering/database/migrate/232-300.sql:19: NOTICE:  CREATE TABLE / PRIMARY KEY will create implicit index "VcimServer_pkey" for table "VcimServer"
CREATE TABLE
CREATE SEQUENCE
DROP TABLE
CREATE INDEX
psql:/opt/vmware/cloudusagemetering/database/migrate/232-300.sql:23: ERROR:  relation "Token" does not exist
psql:/opt/vmware/cloudusagemetering/database/migrate/232-300.sql:24: ERROR:  relation "Token" does not exist
ALTER TABLE
UPDATE 12
ALTER TABLE
psql:/opt/vmware/cloudusagemetering/database/migrate/232-300.sql:33: NOTICE:  CREATE TABLE / PRIMARY KEY will create implicit index "VcopsVmCollection_pkey" for table "VcopsVmCollection"
CREATE TABLE
CREATE SEQUENCE
ALTER TABLE
ALTER TABLE
psql:/opt/vmware/cloudusagemetering/database/migrate/232-300.sql:45: NOTICE:  CREATE TABLE / PRIMARY KEY will create implicit index "VcopsServer_pkey" for table "VcopsServer"
CREATE TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
ALTER TABLE
psql:/opt/vmware/cloudusagemetering/database/migrate/232-300.sql:55: NOTICE:  ALTER TABLE / ADD UNIQUE will create implicit index "VcVcopsCPK" for table "VcVcops"
ALTER TABLE
ALTER TABLE
UPDATE 3
ALTER TABLE
Copying webapp into Tomcat directory
Setting directory ownership and permissions
Allowing execution of support bundles creation script
Adding health check script to cron
Updating appliance version
Starting Tomcat
Using CATALINA_BASE:   /usr/local/apache-tomcat-7.0.14
Using CATALINA_HOME:   /usr/local/apache-tomcat-7.0.14
Using CATALINA_TMPDIR: /usr/local/apache-tomcat-7.0.14/temp
Using JRE_HOME:        /usr/java/jre-vmware
Using CLASSPATH:       /usr/local/apache-tomcat-7.0.14/bin/bootstrap.jar:/usr/local/apache-tomcat-7.0.14/bin/tomcat-juli.jar

If I reboot the appliance, I can login, but get a exception, stating the following:

Message: java.lang.RuntimeException: Exception while executing statement : ERROR: relation "Token" does not exist
errorCode: 0, sqlState: 42P01
Select
  "Token4"."role" as "Token4_role",
  "Token4"."id" as "Token4_id",
  "Token4"."value" as "Token4_value"
From
  "Token" "Token4"

What can I do, besides a fresh install, to get this upgrade running?
Labels (1)
Tags (2)
0 Kudos
3 Replies
dbriccetti
Hot Shot
Hot Shot

Hi. Are you sure you started with a 2.3.2 system? The Token table exists in 2.3.2, so these error messages suggest that you are trying to upgrade from an earlier version.

0 Kudos
PAckermann
Contributor
Contributor

I thought, it is 2.3.2. In the Web-UI I can see 2.3, in vCenter the version is 2.3.0.0 Build 632601. Nevertheless, shouldn't an upgrade from 2.3 to 3.0 be possible? Or do I have to upgrade first to 2.3.2?

0 Kudos
PAckermann
Contributor
Contributor

I went now through the upgrade to 2.3.2 and upgraded succesfully afterwards to 3.0

0 Kudos