Bucketenator
Enthusiast
Enthusiast

vShield 4 on vSphere 5?

Hello,

I'm currently running vSphere ESXi 4.1 / vCenter 4.1 with vShield 4.(1?) and am using the Edge appliances liberally.  

I want to upgrade to vSphere 5, but am happy to leave vShield on 4.x as the upgrade would give me little (although static routes would be nice).

My question is, is this (vSphere 5, vShield 4.x) a supported configuration, or do I have to upgrade to vShield 5 as well? 

Thanks,

Jason D

0 Kudos
3 Replies
sorabhk5
VMware Employee
VMware Employee

This may or may not work.

http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php?

ScreenShot00076.png

Also, check this

https://www.vmware.com/support/vshield/doc/releasenotes_vshield_50.html

Read this only if you are running ESX 4.1 with vShield Zones 4.1, and  want to upgrade to ESXi 5.0. In this situation, you must manually  uninstall vShield Manager 4.1 and Zones 4.1, upgrade to ESXi 5.0, then  install Vshield Manager 1.0 and Zones 1.0 (released with vSphere 5.0).

All opinions expressed here are my personal opinions and not of my employer. Thanks #Sorabh [[ http://sorabhk5.in or @sorabhk5 ]]
Bucketenator
Enthusiast
Enthusiast

Thanks for your response.    I've checked these resources out previously, and none confirm that my proposed vShield/vSphere combination is supported.

I did also see that statement in the release notes, I wonder whether this is really the case for vShield Edge considering that it doesn't have dependencies on any vmkernel modules etc as the other vShield features do (e.g. App) and is simply a virtual appliance.   I would have thought it would just work on either vSphere 4 or 5.

Anyone have any thoughts on that?

Cheers,

Jason D

0 Kudos
jstick1122
VMware Employee
VMware Employee

It may work, like you said there are no modules, but it would be unsupported.