starkov
Contributor
Contributor

Unable to register vShield manager with vCenter - "bad username or password"

Hi,


I'm trying to register the vShield Manager 5.0 (EVAL) with vCenter 5.0 (licensed) after installing the vShield Manager .ova and running "setup".

I'm able to ping and resolve the vCenter Server from vShield. My vCenter runs on a non-domain Windows 2008 Server (WORKGROUP) with local user authentication. The user I'm trying with is part of the local administrator group on Windows 2008 and therefore part of the administrator role on vCenter. I am able to login with vSphere Client using the admin account. Both machines are on the same subnet. I used both FQDN and IP address for the vCenter Server.


But as soon as I try to register the vShield Manager with vCenter using the same admin account I get a "Bad Username or Password" error on vShield and the following log on vCenter:


2011-12-28T13:43:49.448+01:00 [00560 verbose 'ProxySvc Req76037'] New proxy client SSL(TCPStreamWin32(socket=TCP(fd=7724) local=172.21.0.10:443,  peer=172.21.0.140:37078))
2011-12-28T13:43:49.448+01:00 [00560 verbose 'SoapAdapter.HTTPService'] User agent is 'Axis/1.4'
2011-12-28T13:43:49.448+01:00 [00560 verbose 'Default'] [VpxVmomi] Invoking [login] on [vim.SessionManager:SessionManager] session [52a2907b-c827-2a1a-6a5d-74745229927d]
2011-12-28T13:43:49.448+01:00 [00560 verbose 'Default'] [VpxLroList::ThreadMainEntry] Unlocked _propProvider to call into external code
2011-12-28T13:43:49.448+01:00 [00560 verbose 'Default'] [VpxLRO::LroMain] Invoking _currentMain
2011-12-28T13:43:49.448+01:00 [00560 info 'Default' opID=22620d56] [VpxLRO] -- BEGIN task-internal-169172 --  -- vim.SessionManager.login -- 52a2907b-c827-2a1a-6a5d-74745229927d
2011-12-28T13:43:49.448+01:00 [00560 info 'Default' opID=22620d56] Error 1326 authenticating user .\Administrator.
2011-12-28T13:43:49.448+01:00 [00560 info 'Libs' opID=22620d56] [ADS] Failed to lookup account WORKGROUP\Administrator  (err: 1332, [16, 256])
2011-12-28T13:43:49.448+01:00 [00560 error 'Default' opID=22620d56] Failed to authenticate user <Administrator>
2011-12-28T13:43:49.448+01:00 [00560 error 'Default' opID=22620d56] (Log recursion level 2) vim.fault.InvalidLogin
2011-12-28T13:43:49.448+01:00 [00560 error 'Default' opID=22620d56] Section for VMware VirtualCenter, pid=1728, version=5.0.0, build=build-455964, option=Release
-->
2011-12-28T13:43:49.448+01:00 [00560 verbose 'Default' opID=22620d56] [VpxVmomi] Invoke error: vim.SessionManager.login session: 52a2907b-c827-2a1a-6a5d-74745229927d Throw: vim.fault.InvalidLogin
2011-12-28T13:43:49.448+01:00 [00560 verbose 'SoapAdapter.HTTPService' opID=22620d56] User agent is 'Axis/1.4'
2011-12-28T13:43:49.448+01:00 [00560 verbose 'SoapAdapter.HTTPService' opID=22620d56] HTTP Response: Complete (processed 629 bytes)
2011-12-28T13:43:49.448+01:00 [00560 info 'Default' opID=22620d56] [VpxLRO] -- FINISH task-internal-169172 --  -- vim.SessionManager.login -- 52a2907b-c827-2a1a-6a5d-74745229927d
2011-12-28T13:43:49.448+01:00 [00560 info 'Default' opID=22620d56] [VpxLRO] -- ERROR task-internal-169172 --  -- vim.SessionManager.login: vim.fault.InvalidLogin:
--> Result:
--> (vim.fault.InvalidLogin) {
-->    dynamicType = <unset>,
-->    faultCause = (vmodl.MethodFault) null,
-->    msg = "",
--> }
--> Args:
-->
--> Arg userName:
--> "Administrator"
--> Arg password:
--> (not shown)
-->
--> Arg locale:
-->
2011-12-28T13:43:49.448+01:00 [00560 verbose 'Default'] [VpxLRO::ClearCurrentMain] Clearing _currentMain


I tried every possible syntax for my login (with WORKGOUP\[username], [hostname]\[username], .\[username], etc. but vCenter rejects everything.
The untrusted certificate warning and the logs on vCenter means that HTTPS connection from vShield manager to vCenter is working.

I don't know where else to look...

Regards,
starkov

0 Kudos
3 Replies
sorabhk5
VMware Employee
VMware Employee

You are doing it the right way. All you have to do is enter the vcenter admin username and password. Dont add anything like domain name or workgroup. Just <username> should be enough in this case

ScreenShot00081.png

This issue may occur if you use non-standard English characters (such as ä) in the password.
Note: Either a Windows account local to the vCenter server or an AD or Domain account that the vCenter server is part of is used when connecting to the vCenter server with the vCenter client.
To resolve this issue, use only standard English characters in both your user name and password.

See the KB: http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=1009139

and http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=2005947

All opinions expressed here are my personal opinions and not of my employer. Thanks #Sorabh [[ http://sorabhk5.in or @sorabhk5 ]]
starkov
Contributor
Contributor

Hi Sorabh

Thanks for the tip.

I don't have any umlauts in my passwords, but as soon as there is a PLUS sign in the password, vCenter won't accept the login.

I tried with different special characters but only the "+" seems to cause problems. I guess this is a bug.

Anyway, as long as I use passwords without the "+" it works.

Thanks for pointing me in the right direction.

regards,

starkov

0 Kudos
sorabhk5
VMware Employee
VMware Employee

Thanks for updating.... Will check the same else log the bug internally Smiley Wink

All opinions expressed here are my personal opinions and not of my employer. Thanks #Sorabh [[ http://sorabhk5.in or @sorabhk5 ]]
0 Kudos