Commander
Commander

Unable to deploy VXLAN in vSphere 5.5 with vmknic error

Hello everyone,

Over two weeks I've tried different ways to deploy VXLAN unsuccessfully. I follow the VXLAN deployment guide but I've always the same error message in ESXi hosts.

XXX com.vmware.vxlan.vmknic.initfail.formatOnHost not found XXX

vxlan-vmknic-error.png

My vSphere platform vCNS are the last version both and licensed.

I found this blog post with the same error but I've not vCloud deployed yet when I enable VXLAN. VMware VXLAN Host Preparation: Add virtual NIC: Unknown error | Lostdomain.org

Best regards,

Jose Luis Gomez

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
Tags (3)
10 Replies
Commander
Commander

Hello everyone,

I've more information about this issue after tested some configurations:

  • ESXi 5.5 (any release) vCenter 5.5 (any release) vDS (5.1 & 5.5 version) vCNS (5.5.2) FAIL
  • ESXi 5.5 (any release) vCenter 5.5 (any release) vDS (5.1 & 5.5 version) vCNS (5.5.0) FAIL
  • ESXi 5.1 (any release) vCenter 5.5 (any release) vDS (5.1 version) vCNS (5.5.2) WORKS

Best regards,

Jose Luis Gomez

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
Commander
Commander

Hello everyone,

More information of ESXi vmkernel.log

vmkernel.log:2014-06-29T10:28:46.553Z cpu1:33164)Net: 221: Created new Tcpip Instance at 0x41094b547ac0, index 1, name: vxlan, ccalgo: newreno, socketMax: 11000

vmkernel.log:2014-06-29T10:30:39.712Z cpu1:35661)vxlan: VDL2Init:561: Using netstack 'vxlan'

vmkernel.log:2014-06-29T10:30:39.713Z cpu1:35661)NetDVS: 1491: register client for command com.vmware.net.vxlan.conncheck.receive successful

vmkernel.log:2014-06-29T10:30:39.713Z cpu0:35664)vxlan: VDL2CPWorldFunc:314: Control plane world starts

vmkernel.log:2014-06-29T10:30:39.713Z cpu1:35661)vxlan: VDL2_CPActivate:3753: VDL2 control plane is activated

vmkernel.log:2014-06-29T10:30:39.713Z cpu1:35661)vxlan: VDL2Init:646: VDL2 initialization succeeded.  Module ID:96

vmkernel.log:2014-06-29T10:30:45.279Z cpu0:33947 opID=7ba4157c)vxlan: VDL2_CreateInstance:2645: VDL2 instance[DvsPortset-0] created

vmkernel.log:2014-06-29T10:30:45.439Z cpu1:33959 opID=b1ede7d1)DVSDev: DVSDevDataSet:993: setting data com.vmware.net.vxlan.vmknic on port 9

vmkernel.log:2014-06-29T10:30:45.489Z cpu1:33959 opID=1457cb28)WARNING: vxlan: VDL2PortPropSet:170: Failed to create VXLAN IP vmknic on port[0x3000004] of VDS[DvsPortset-0] : Failure

vmkernel.log:2014-06-29T10:30:45.489Z cpu1:33959 opID=1457cb28)WARNING: NetDVS: 2017: failed to init client for data com.vmware.net.vxlan.vmknic on port 9

vmkernel.log:2014-06-29T10:30:50.527Z cpu0:33959 opID=754ceee0)DVSDev: DVSDevDataSet:993: setting data com.vmware.net.vxlan.vmknic on port 9

vmkernel.log:2014-06-29T10:30:50.559Z cpu1:33950 opID=82ab34ac)WARNING: vxlan: VDL2PortPropSet:170: Failed to create VXLAN IP vmknic on port[0x3000005] of VDS[DvsPortset-0] : Failure

vmkernel.log:2014-06-29T10:30:50.559Z cpu1:33950 opID=82ab34ac)WARNING: NetDVS: 2017: failed to init client for data com.vmware.net.vxlan.vmknic on port 9

vmkernel.log:2014-06-29T10:30:56.441Z cpu1:35305 opID=7fe0be29)DVSDev: DVSDevDataSet:993: setting data com.vmware.net.vxlan.vmknic on port 9

vmkernel.log:2014-06-29T10:30:56.477Z cpu0:35306 opID=30b4791d)WARNING: vxlan: VDL2PortPropSet:170: Failed to create VXLAN IP vmknic on port[0x3000006] of VDS[DvsPortset-0] : Failure

vmkernel.log:2014-06-29T10:30:56.477Z cpu0:35306 opID=30b4791d)WARNING: NetDVS: 2017: failed to init client for data com.vmware.net.vxlan.vmknic on port 9

Best regards,

Jose Luis Gomez

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
VMware Employee
VMware Employee

Hi,

    Can you also post the VCNS logs during the same time period? Meanwhile you can also try preparing the host to a new DVS if you haven't tried yet.Hope the issue is not specific to stateless host?

Cheers,
Sree | CKA|CKAD|VCIX-3X| VCAP-4X| VExpert 4x
0 Kudos
Commander
Commander

Hi Sree,

I haven't the exactly log but I have other with the same error. You can find it attached.

Best regards,

Jose Luis Gomez

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
Enthusiast
Enthusiast

Hey!

I have a similar issue except my error sounds a bit different:

XXX com.vmware.vxlan.instance.notexist.fullFromat not found XXX

My env is: ESXi 5.5, vCenter 5.5, vShield Manager 5.5.2, vCloud Director 5.6 beta 4

Have you managed to solve your issue?

0 Kudos
Enthusiast
Enthusiast

Hi

Had a similar error, trying to expand a vCD cluster, no vxlan vmknic created either.  The resolution we got to with help from VMware Support was to reconnect the vShield Manager to vCenter (in vShield settings select the vCenter, enter credentials again and hit OK).  After that putting a host into maint mode correctly initiated the vxlan setup; all we needed to do after that was fix the vmknic IP address and we're off.

Any odd vxlan behaviour - reconnect vShield to vCenter.

Contributor
Contributor

nzjono you genius!  We had exactly the same issue after removing the VXLAN config, when we ran the preparation section again the following errors were thrown in the vmkernel log:

2014-09-04T13:27:20.805Z cpu1:34134 opID=2fb6f731)WARNING: vxlan: VDL2PortPropSet:170: Failed to create VXLAN IP vmknic on port[0x5000005] of VDS[DvsPortset-0] : Failure

2014-09-04T13:27:20.805Z cpu1:34134 opID=2fb6f731)WARNING: NetDVS: 2017: failed to init client for data com.vmware.net.vxlan.vmknic on port 130

Re-registering vShield Manager with vCentre worked a treat.  Thanks for posting!

0 Kudos
Enthusiast
Enthusiast

Glad to have helped!  We spent a fair while on this but the solution literally took seconds, hopefully this saves others from having to go through that Smiley Happy

0 Kudos
Contributor
Contributor

Quick question... Does this reconnection cause any downtime on vCloud Director?

Thanks,

Cristina

0 Kudos
Contributor
Contributor

It didn't in our case, we've had to do it a couple of times since (when a password has been reset for the admin account etc.).

0 Kudos