Highlighted
Contributor
Contributor

The remote server returned an error: (406) Not Acceptable

Hi all,

I'm new with Cloud Director and PowerCLI and I would like connect my vCD to create some stuffs.  But when I try to connect my vCD, I receive the following error:

Connect-CisServer The remote server returned an error: (406) Not Acceptable.. vmware

Executed command :

Connect-CIsServer -server xyz.com

Any idea is welcome...

Thx

0 Kudos
7 Replies
Highlighted
User Moderator
User Moderator

Any extra information when you add the Verbose switch?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Contributor
Contributor

Very few info on this error 😕

Connect-CIsServer : 14-06-18 13:56:16 Connect-CisServer The remote server returned an error: (406) Not Acceptable..

At line:3 char:1

+ Connect-CIsServer -server server.xyz

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : NotSpecified: (:) [Connect-CisServer], CisException

    + FullyQualifiedErrorId : VMware.VimAutomation.Cis.Core.Impl.V1.Service.CisConnectionService.SessionCanNotBeCreated,VMware.VimAutomation.Cis.Core.Commands.Cmdlets.ConnectCisServer

0 Kudos
Highlighted
User Moderator
User Moderator

Do you get access through a browser?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Contributor
Contributor

Yes of course.

And I'm using:

PowerCLI Version

----------------

   VMware PowerCLI 6.5 Release 1 build 4624819

---------------

Component Versions

---------------

   VMware Cis Core PowerCLI Component 6.5 build 4624453

   VMware VimAutomation Core PowerCLI Component 6.5 build 4624450

   VMware Vds PowerCLI Component 6.5 build 4624695

   VMware Cloud PowerCLI Component 6.5 build 4624821

With VMware vCloud Director 9.1.0.7905680

I tried the same operation with a machine in the same IP range to avoid any FW problems and I've another error message but no more explicit 😕

PS C:\Windows\system32> Connect-CIsServer -server server.xyz -Verbose

Connect-CIsServer : 14-06-18 15:53:49 Connect-CisServer An error occurred while sending the request..

At line:1 char:1

+ Connect-CIsServer -server server.xyz -Verbose

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : NotSpecified: (:) [Connect-CisServer], CisException

    + FullyQualifiedErrorId : VMware.VimAutomation.Cis.Core.Impl.V1.Service.CisConnectionService.SessionCanNotBeCreated,VMware.VimAutomation.Cis.Core.Commands.Cmdl

   ets.ConnectCisServer

0 Kudos
Highlighted
User Moderator
User Moderator

It must be something with protocol or connection, but I can't see what exactly.

Perhaps a network trace could show what goes wrong?

Sorry, but without any further means to analyse I'm out of ideas I'm afraid.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
VMware Employee
VMware Employee

I think the small 's' is creating the trouble here.

Can you check using the command :

Connect-CIServer -server xyz.com

instead of Connect-CIsServer -server xyz.com

0 Kudos
Highlighted
Contributor
Contributor

Hi all,

Thanks for your assistance but for your information it was probably linked to a PowerCLI installation problem.

I removed PowerCLI (with Windows add/remove feature) then reinstall it (Install-Module -Name VMware.PowerCLI -AllowClobber) and everything is working fine now ...

I hate this kind of problem and solution 😞

0 Kudos