dakkfy1
Contributor
Contributor

New-CIVM throws Unknown IP Addressing Mode "MANUAL".. connected to network "none"

Jump to solution

Hi,

Im trying to run the following command:

New-CIVM -Name ("TestVM-2") -VMTemplate $templateVM -VApp $MYvApp -ComputerName ("MyComputer") -ErrorAction Stop

But it throws the following command:

New-CIVM [ ... ] Invalid network parameter: Unknown IP Addressing Mode "MANUAL" for vNIC 2 on VM "TestVM-2" connected to network "none".

However none of the NICs in the template has the setting combination (MANUAL and network=none) mentioned in the error message... Network section for the VM looks like this:

$templateVM.ExtensionData.Section[0].NetworkConnection


Network : Net-2
NeedsCustomization : False
NetworkConnectionIndex : 2
NetworkAdapterType : VMXNET3
IpAddress : 172.22.1.13
ExternalIpAddress :
IpAddressAllocationMode : MANUAL
IsConnected : True
AnyAttr :
VCloudExtension :

Network : none
NeedsCustomization : True
NetworkConnectionIndex : 0
NetworkAdapterType : VMXNET3
IpAddress :
ExternalIpAddress :
IpAddressAllocationMode : NONE
IsConnected : False
AnyAttr :
VCloudExtension :

Network : Net-1
NeedsCustomization : False
NetworkConnectionIndex : 1
NetworkAdapterType : VMXNET3
IpAddress : 172.21.1.12
ExternalIpAddress :
IpAddressAllocationMode : MANUAL
IsConnected : True
AnyAttr :
VCloudExtension :

 

The same command was working a few weeks ago, but the IT crew has been fiddling with the vcloud to get rid of the flash portal lately...

Any idea what causes this? Would it be possible to change the NIC settings before trying to push the change? The web portal can make new VMs using the same template just fine, but its slow as f....

0 Kudos
1 Solution

Accepted Solutions
dakkfy1
Contributor
Contributor

It seems like the source of the problem is that when calling New-CIVM most of the network config is wiped clean from the template except the IP addressing mode field.

Creating a template with Addressing mode set to "none" instead of "Manual" lets us deploy VMs just fine.

However i question the reasoning behind allowing templates to be made with invalid configurations that cannot be solved in the New-CIVM call.
Perhaps a new parameter to create and pass new NetworkConnection configuration would be in order?

ie:

New-CIVM -Name ("TestVM-2") -VMTemplate $templateVM -VApp $MYvApp -ComputerName ("MyComputer") -NetworkConnection $tmpNicSettings -ErrorAction Stop

Or similar

View solution in original post

0 Kudos
2 Replies
dakkfy1
Contributor
Contributor

It seems like the source of the problem is that when calling New-CIVM most of the network config is wiped clean from the template except the IP addressing mode field.

Creating a template with Addressing mode set to "none" instead of "Manual" lets us deploy VMs just fine.

However i question the reasoning behind allowing templates to be made with invalid configurations that cannot be solved in the New-CIVM call.
Perhaps a new parameter to create and pass new NetworkConnection configuration would be in order?

ie:

New-CIVM -Name ("TestVM-2") -VMTemplate $templateVM -VApp $MYvApp -ComputerName ("MyComputer") -NetworkConnection $tmpNicSettings -ErrorAction Stop

Or similar

0 Kudos
bdmpastx
Contributor
Contributor

Even without powershell, we had issues of setting the Manual IP in the UI. We found out that there is some bug in the API calls that have to be fixed and they are addressing it in 10.2.1 coming Jan 10, 2021. Let's hope this fixes both the PowerCLI and API calls.

We did work around this by letting it deploy the VM as is, then after completion, modify the settings for the NIC in another edit. It is painful but kept our D2D ops going.

Tags (1)
0 Kudos