PCMA_IT
Contributor
Contributor

vcenter server upgrade error Failed dependencies: eventlog is obsoleted by (installed) syslog-ng-3.1

Hi i am trying to upgrade 7.0.2.00100 to 7.0.2.00200 from CLI

i face the following error as per the log file :  /var/log/vmware/applmgmt/software-packages.log

2021-06-07T08:17:29.158 [55924]DEBUG:vmware.vherd.base.software_update:STDERR: error: Failed dependencies:
eventlog is obsoleted by (installed) syslog-ng-3.17.2-1.ph3.x86_64

2021-06-07T08:17:29.158 [55924]DEBUG:vmware.vherd.base.software_update:Test transaction failed to update package
out=
error=error: Failed dependencies:
eventlog is obsoleted by (installed) syslog-ng-3.17.2-1.ph3.x86_64

rc=54

2021-06-07T08:17:29.158 [55924]CRITICAL:root:Installation process failed
2021-06-07T08:17:29.158 [55924]CRITICAL:root:Test transaction failed to update packages
2021-06-07T08:17:29.158 [55924]DEBUG:root:Test transaction failed to update packages

Any Ideas please.

Regards.

Najeeb Hajji

0 Kudos
1 Reply
PCMA_IT
Contributor
Contributor

I have manually removed the package and the upgrade worked:

rpm -e syslog-ng-3.17.2-1.ph3.x86_64

Many thanks