TinySword
Contributor
Contributor

vcenter ha state out of sync

1、The reason for this problem is that I upgraded vcenter 6.7u1b directly to 6.7u3g, and I did the upgrade without any awareness to check the upgrade compatibility document.

2、The manifestation of this problem is that every time I log in to vcenter, there will be an out of sync and automatic failover error message in the vcenter ha configuration interface.

So I logged in to the vcenter appliance and copied the log locally and found the problem. Every time I log in to vcenter, the com.vmware.vcIntegrity.vcIntegrity:6.7.0.xxxx plug-in will continuously delete the replication synchronization between the active and passive nodes.

3、Finally I found the location of the name. It is not a file but a folder. I set a chattr +i attribute to all the files in this folder. The problem was solved and it took three months. No problem was found in the time, except that sometimes the taskbar at the bottom disappears, you need to click the bottom at the moment of refresh to make the taskbar appear.

chattr +i -R /etc/vmware/vsphere-ui/cm-service-packages/com.vmware.cis.vsphereclient.plugin/com.vmware.vcIntegrity.vcIntegrity:6.7.0.xxxx

未命名图片1.png

未命名图片2.png

未命名图片.png

0 Kudos
1 Reply
nachogonzalez
Expert
Expert

Hope you are doing fine:


Do you have your passive and witness nodes configured?
Are both powered on and connected?

Have you used automatic deploy or manual deploy?

A test you might do is to disable vCenter HA and enable it back

0 Kudos