albatros99
Enthusiast
Enthusiast

vcenter 7 appliance is running low on memory (12GB)

i have VMware vCenter Server Version 7.0.1.00100 Build 17004997

Running the appliance with original configuration with 12.288 MB (12GB) i become the error appliance is running low on memory.

when i try to give more memory (16GB or 24GB) i become the message, that my license are not enough.

Also i am not able to add a vsphere7-host on this vcenter 7, error message is false username or password

Message is: Cannot complete login due to an incorrect username or password.

how can help?

12 Replies
nachogonzalez
Commander
Commander

Is is possible that you have the vCenter foundations license?

0 Kudos
albatros99
Enthusiast
Enthusiast

What is a vCenter fondations license?

i have buy vsphere 6 essentials and vsphere 7 essentials and the corresponding vcenter license 6 and 7

 

0 Kudos
scott28tt
VMware Employee
VMware Employee

@albatros99 

If you bought the vSphere Essentials Kit you will have a vCenter Server Essentials license as part of that: https://blogs.vmware.com/vsphere/2018/10/vcenter-server-licensing-options.html

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------
VMware Training & Certification blog
0 Kudos
albatros99
Enthusiast
Enthusiast

i have a valid license for vcenter 7 and the license was key in an accepted.

the two hosts are also correct licensed with vmware vsphere essentials 6, this host can be load in vcenter, the second host is licensed with vsphere essentials 7, and this host can be registered, then it will be removed with the message "incorrect username or password". Username and password are correct!

what can i do?

0 Kudos
e_espinel
Commander
Commander

Hello.
You can show the entered licenses from the vcenter, of course hiding the key.

That way we will know what kind of licenses you have and how many you have.

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
albatros99
Enthusiast
Enthusiast

i have join a png file with the licenses, vcenter 6 can't be key in

 

0 Kudos
albatros99
Enthusiast
Enthusiast

 
0 Kudos
e_espinel
Commander
Commander

Hello
You would have 2 Essentials kits, one version 6 and one version 7 so you would have a vcenter server and 3 hosts (2CPU) for each kit.

In the image you sent from vcenter Essentials 7 I see the following licenses entered:
vcenter Essentials 7
VMware vSphere Essentials 6
vSphere Essentials 7

Since the vcenter is Essentials, I am not sure that it can manage 2 different types of tenders (Essentials).

.
Is there any reason why I need to have this mixed license burning?.

I will keep looking, but your case is out of the ordinary

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
albatros99
Enthusiast
Enthusiast

Yes, there is a reason. My old server ibm x3650m3 is not compatible with vsphere 7 and the server is eol and the disk space is full. I have buy a hp server dl380 gen 9 with more memory and disk space. When the two server are in vcenter, I’ll will migrate all virtual machines on the new server.

i have change today the tiny installation to a small vcenter installation, with the same issue.

i am able to add the ibm server with vsphere essentials 6, but not the the hp server with vsphere essentials 7.

vcenter 7 is installed as virtual machine on the hp server and licensed correctly.

the error message “incorrect username or password” is not the correct issue, the host will be added and then removed with this message!
who can help or analyze the problem?

0 Kudos
schudakov
Contributor
Contributor

You no need add RAM to VM.

 

Connect SSH to vCenter Server Appliance, enter bash command "shell".

List current service RAM set (save before edit):

cloudvm-ram-size -l

View memory usage statistic:

cloudvm-ram-size -S

If value in "CurrentMB" above "AllocatedMB" - may, but not neccesary, need up service set.

Worked for me to solve problem in default VCSA installation:

cloudvm-ram-size -C 1024 vmware-vpostgres
service-control --stop vmware-vpostgres;service-control --start vmware-vpostgres;
cloudvm-ram-size -C 2048 vsphere-ui
service-control --stop vsphere-ui;service-control --start vsphere-ui;

Refresh Health status on vCenter Server Manager page.

0 Kudos
Undertaker45
Contributor
Contributor

The topic is old, but I did not see the answer.

I made a fresh installation of ESXI and VCSA 7 versions, and hit the same problem, I still have to figure problem out the memory.


And adding a new ESXI host took a long time. I have tried a lot of things described in the community. I was able to add new host only using the ROOT account on ESXI, which was immediately deactivated after a fresh installation according to the security policy(habit).

I do not understand what permissions an account different than root should have, if administrator rights are granted.

It is checked on 2 hosts, it works!

PS. root account may deleted after host added.

0 Kudos
Ajay1988
VMware Employee
VMware Employee

For memory warning on VCSA 7 for tiny environment >> Please try stopping the vmware-pod service and check after 15-20 mins if the warning again triggers.  Worst case is to increase memory by 2 or 4 GB . 

https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vcenter.install.doc/GUID-88571D8A-46E1-464D...

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos