zhoupeng9298451
Contributor
Contributor

vCenter Server Appliance 7 install step2 Unable to start the Service Control Agent.

 
Messages
 

Error

Unable to start the Service Control Agent.

Resolution

 
 
A problem occurred during setup. Services might not be working as expected.
30%
A problem occurred while - Starting VMware Service Control Agent...

 

7 Replies
msripada
Virtuoso
Virtuoso

Its hard to tell what is the problem based on the error as I do not see any reported issue Kb for the respective service. You can check ntp, dns. 

check the /var/log/firstboot/sca-firstboot-stderr.log from 7.0 vcsa 

thanks,

MS

steveyu
Contributor
Contributor

I have some problem. From my install. 

#cat scafirstboot.py_9708_stderr.log

2021-07-17T22:16:19.001Z Warning: Key - log4j.appender.file.File not found
2021-07-17T22:18:24.723Z ERROR starting sca rc: 2, stdout: , stderr: Start service request failed. Error: Service crashed while starting

2021-07-17T22:18:24.724Z Traceback (most recent call last):
File "/usr/lib/vmware-sca/firstboot/scafirstboot.py", line 206, in start_service
super(ScaFB, self).start_service()
File "/usr/lib/vmware/site-packages/cis/firstboot.py", line 266, in start_service
service_start(self.get_eff_service_name())
File "/usr/lib/vmware/site-packages/cis/utils.py", line 1084, in service_start
raise ServiceStartException(svc_name)
cis.exceptions.ServiceStartException: {
"detail": [
{
"id": "install.ciscommon.service.failstart",
"translatable": "An error occurred while starting service '%(0)s'",
"args": [
"sca"
],
"localized": "An error occurred while starting service 'sca'"
}
],
"componentKey": null,
"problemId": null,
"resolution": null
}

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/lib/vmware-sca/firstboot/scafirstboot.py", line 336, in Main
fbObj.start_service()
File "/usr/lib/vmware-sca/firstboot/scafirstboot.py", line 213, in start_service
problemId = 'com.vmware.sca.control.start')
cis.baseCISException.BaseInstallException: {
"detail": [
{
"id": "com.vmware.sca.control.start",
"translatable": "Unable to start the Service Control Agent.",
"localized": "Unable to start the Service Control Agent."
}
],
"componentKey": "sca",
"problemId": "com.vmware.sca.control.start",
"resolution": {
"id": "com.vmware.sca.internal.resolution",
"translatable": "Search for these symptoms in the VMware knowledge base for any known issues and possible workarounds. If none can be found, collect a support bundle and open a support request.",
"localized": "Search for these symptoms in the VMware knowledge base for any known issues and possible workarounds. If none can be found, collect a support bundle and open a support request."
}
}

2021-07-17T22:18:24.726Z sca firstboot failed

szoszo9
Contributor
Contributor

Any possible stolution?
Still exist for Me on steup vCenter 7.0.2

0 Kudos
lucarobusto_arp
Enthusiast
Enthusiast

same issue on an internal small test lab.

 

did you solve?

0 Kudos
Ajay1988
VMware Employee
VMware Employee

Please check the sca.log file under /var/log/vmware/sca/  (new vCSA) .

Mostly a communication issue

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
Amine3
Contributor
Contributor

Hi 

I have the same problem
Did you find the solution

0 Kudos
gzlebir
Contributor
Contributor

We have the same issue. Anybody found a solution?

0 Kudos