vinay1
Enthusiast
Enthusiast

vCenter Server 5.1 Installation

Hi Guys,

I have tried to migrate vCenter Server 5.1 from physical server to a VM and while installation and end up with error message "Error 20010.Failed to configure LookupService". checked log files

in log file vm_vim_ls.log

-------------------

main  TRACE com.vmware.vim.lookup.install.database.DbConnection] Connecting to: jdbc:sqlserver://;serverName=XXX01;instanceName=XXX2001;port=1433;databaseName=RSA

[2014-12-07 11:05:21,189 main  TRACE com.vmware.vim.lookup.install.database.CreateDbSchema] Executing SQL:  CREATE TABLE [LS_SERVICE]( [ID]     INT NOT NULL IDENTITY, [OWNER_ID]    VARCHAR(255), [VERSION]    VARCHAR(255) NOT NULL, [DESCRIPTION]   NVARCHAR(2048), [FRIENDLY_NAME]   NVARCHAR(255), [SERVICE_TYPE]   VARCHAR(1024) NOT NULL, [PRODUCT_ID]         VARCHAR(255))

[2014-12-07 11:05:21,189 main  ERROR com.vmware.vim.lookup.install.PreInstaller] Install cannot proceed due to error.

com.microsoft.sqlserver.jdbc.SQLServerException: There is already an object named 'LS_SERVICE' in the database.

-----------------------

in log file vminst.log

-----------------------------

VMware Single Sign On-build-878838: 12/06/14 10:55:36 ERROR: Unable to retrieve the VC DB Instance Name

VMware Single Sign On-build-878838: 12/07/14 00:21:42 Cannot query key value HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\InstalledInstances: 2
VMware Single Sign On-build-878838: 12/07/14 00:21:42 INFO: Not found in 32 bit hive. Looking in 64 bit hive.
VMware Single Sign On-build-878838: 12/07/14 00:21:42 Cannot query key value HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\InstalledInstances: 2
VMware Single Sign On-build-878838: 12/07/14 00:21:42 End Logging
VMware Single Sign On-build-878838: 12/07/14 00:21:42 Begin Logging
VMware Single Sign On-build-878838: 12/07/14 00:21:42 --- CA exec:

Please suggest what action need to be taken.

regards

VK

0 Kudos
7 Replies
rcporto
Leadership
Leadership

Already checked this KB article: VMware KB: Installing vCenter Single Sign-On fails with the error: Error 20010: Failed to configure ...

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
0 Kudos

Can you make sure VC DB is properly configured?

ERROR: Unable to retrieve the VC DB Instance Name

Also share below log files:

vm-sso-javaLib.log file (located in %temp%)

%TEMP%\vm_ssoreg.log file

------------------------------------------------------------------------- Follow me @ www.vmwareguruz.com Please consider marking this answer "correct" or "helpful" if you found it useful T. Sateesh VCIX-NV, VCAP 5-DCA/DCD,VCP 6-NV,VCP 5 DCV/Cloud/DT, ZCP IBM India Pvt. Ltd
0 Kudos
vinay1
Enthusiast
Enthusiast

Hi Sateesh, I have checked the log vm-sso-javalib.log and seems there is no issue with DB connectivity but seems it is failed at table 'LS_CONFIGURATION'. please refer the logs. com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Successfully establish database connection [2014-12-07 10:57:26,890] INFO  765[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Database scripts rsaIMSLiteMSSQLDropUsers.sql and rsaIMSLiteMSSQLDropSchema.sql will be used [2014-12-07 10:57:26,890] INFO  765[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Format flag is set, database will be formated. [2014-12-07 10:57:26,890] INFO  765[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Start database formating... [2014-12-07 10:57:26,890] INFO  765[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Check for database existence... [2014-12-07 10:57:26,999] INFO  874[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - fetching the data from database server to check database existence [2014-12-07 10:57:26,999] INFO  874[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - SSO Database Schema does not exist. Try to drop Look up Schema if this is left out... [2014-12-07 10:57:27,015] INFO  890[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - fetching the data from database server to check database existence [2014-12-07 10:57:27,015] INFO  890[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Column Name : TABLE_CAT value : RSA [2014-12-07 10:57:27,015] INFO  890[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Column Name : TABLE_SCHEM value : dbo [2014-12-07 10:57:27,015] INFO  890[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Column Name : TABLE_NAME value : LS_SERVICE [2014-12-07 10:57:27,015] INFO  890[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Column Name : TABLE_TYPE value : TABLE [2014-12-07 10:57:27,015] INFO  890[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Column Name : REMARKS value : null [2014-12-07 10:57:27,015] INFO  890[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Lookup Service schema exits, try to drop the schema [2014-12-07 10:57:27,015] INFO  890[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Start formating LookupService database schema.... [2014-12-07 10:57:27,030] INFO  905[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Running Sql Statement from sql file LS_MSSQL_DropSchema.sql [2014-12-07 10:57:27,030] INFO  905[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - Query which is going to be executed :    DROP TABLE LS_CONFIGURATION    [2014-12-07 10:57:27,030]ERROR  905[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.error(?:?) - Failed to format the Database com.microsoft.sqlserver.jdbc.SQLServerException: Cannot drop the table 'LS_CONFIGURATION', because it does not exist or you do not have permission. [2014-12-07 13:23:21,155] INFO    0[main] - com.vmware.vim.installer.core.logging.CoreLoggerImpl.info(?:?) - IP stack is fine regards VK

0 Kudos

From the given logs I notice that RSA_USER & RSA_DBA were not granted enough permissions at SQL DB.

Did you try to run the DB scripts from the installation bundle? (on SQL server)

------------------------------------------------------------------------- Follow me @ www.vmwareguruz.com Please consider marking this answer "correct" or "helpful" if you found it useful T. Sateesh VCIX-NV, VCAP 5-DCA/DCD,VCP 6-NV,VCP 5 DCV/Cloud/DT, ZCP IBM India Pvt. Ltd
0 Kudos
vinay1
Enthusiast
Enthusiast

the RSA_USER and RSA_DBA has appropriate access. as currently we restored the services back to the old vCenter server and its all working normal. so I think its not a permission issue. I observed some error in

imstrace log

ERROR, ServerName,,,,LDAP Server connection test failed javax.naming.AuthenticationException: GSSAPI [Root exception is javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Server not found in Kerberos database (7))]]

regards

VK

0 Kudos
vinay1
Enthusiast
Enthusiast

Hi Sateesh,

in log file vm_vim_ls.log

main  TRACE com.vmware.vim.lookup.install.database.DbConnection] Connecting to: jdbc:sqlserver://;serverName=XXX01;instanceName=XXX2001;port=1433;databaseName=RSA

We are using a separate server for SQL DB instance for the vCenter installation. so there could be some issue with the jdbc connection. I am not sure but assume the port number for SQL DB should not be the default one.

Please suggest if this could be the issue or if any.

regards

VK

0 Kudos

Thanks for your inputs Vinay.

Yes we have another view of Dynamic port at SQL console.

I saw that you are trying with 1433 port but SQL Admin might configured with dynamic port which will be in 60,xxx range.

Can you double check those values?

------------------------------------------------------------------------- Follow me @ www.vmwareguruz.com Please consider marking this answer "correct" or "helpful" if you found it useful T. Sateesh VCIX-NV, VCAP 5-DCA/DCD,VCP 6-NV,VCP 5 DCV/Cloud/DT, ZCP IBM India Pvt. Ltd
0 Kudos