VMware Cloud Community
VMAdmin902
Contributor
Contributor

vCenter Datastore Issue.

Very strange issue with vCenter Server v4.1 (ESXi v 4.1).

I have a VM on Datastore04. Two days ago ALL FILES disappeared from the VM folder and the VM would not start up. I restored the files to another Datastore/Folder and continued on.

When I started my troubleshooting process, I found a few starnge things;

1. When browing to datastore (Using vCenter Datastore Browser) that contains the empty folder, I try and delete and it tells me that the folder is not found. So the folder cannot be deleted, even though I can see it.

2. If I go to the web based datastore browser I CAN SEE ALL OF THE FILES. I can download the VMDK, and run the machine locally.

Any ideas what is going on? I'd like to be able to delete the folder/files.

Reply
0 Kudos
3 Replies
Troy_Clavell
Immortal
Immortal

Hello and Welcome to the Forums!

you may need to restart the management agents on the ESXi Host where the VM is currently registered.  This will refresh the vCenter agent and may clear up any inconsistencies.

Reply
0 Kudos
VMAdmin902
Contributor
Contributor

Thanks for the reply. I tried to restart the Managment Agents and it didn't help. Other files and folders are visible on the same datastore.

Reply
0 Kudos
Troy_Clavell
Immortal
Immortal

If you connect directly to the ESXi Host that has the registered VM and browse the datastore, can you see the folder and try and delete it?

If that doesn't work, then I would say restart your vCenter Server Service.

Also, just in case... The VM in question doesn't have an ISO or anything mounted to the CD/DVD drive?

Reply
0 Kudos