LE2Strat
Contributor
Contributor

vCenter Converter Plugin Error (Version 4.1.1) 404, Not Found Error

After upgrading our vCenter to 4.1, it looks like our converter plugin is now broken.  When you try to enable it you get an error:

An internal error occurred in the vSphere Client.

Details:  The remote server returned an error:  (404) Not Found.

I have seen some other people report the plugin errors, but I haven't seen anyone say they are getting the 404 not found error at all.

The downloaded the logs, and the summary log states:

--------------------------------------------------------------------------------

System.Net.WebException: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
   at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)
______________________________________________

Any ideas anyone?   Happens on all machines with the vSphere client.  Even the local vCenter server and fresh client installs.

Other plugins like the Update manager install with no issue.

0 Kudos
7 Replies
Troy_Clavell
Immortal
Immortal

0 Kudos
LE2Strat
Contributor
Contributor

No, it doesn't.  This occurs even if you run the vSphere client locally on the vSphere server.

0 Kudos
Troy_Clavell
Immortal
Immortal

...so you are saying the plugin is installed on the vCenter Server in the same directory as the vCenter Install?

0 Kudos
LE2Strat
Contributor
Contributor

Yes...everything is installed on the D:\ partition

D:\Program Files(x86)\VMware

0 Kudos
GavinY
Contributor
Contributor

Agreed with Troy. You can check on if your converter plugin was installed on the same directory as vCenter (VMware infrastructure directory). I see you have the converter plugin 4.1. You might want to consider using newer version 4.2. It works nicely in our environment.

0 Kudos
LE2Strat
Contributor
Contributor

Thanks, but I am just going to call VMWare support.  Everything is installed on the same drive.  I want to get the 4.1 convertor working before we update to 4.2  Thanks though.

0 Kudos
dingeem
Contributor
Contributor

I just installed vcenter 4.1...then installed converter.  When I try to download and install the plugin (which is 4.2) it fails with this error?

any idea?

0 Kudos