SSpiers
Contributor
Contributor

vCenter 7 error - no healthy upstream

Hi All,

I'm working on brand new ESXi 7.0.0 deployment and have run into an issue when deploying vCenter 7.

When browsing to the vCenter UI I receive a "no healthy upstream" error.

I can access vCenter Server Management without issue.

I've done some googling and have been pointed towards certificate issues however my Leaf and Root certs are showing as valid.

All of the services which are set to Automatic start are running without any errors or warnings.

Is there a documented fix for this issue?

61 Replies
milindng
Enthusiast
Enthusiast

I am  getting same error. I have checked and found my vcenter ip is already configure with static IP.

I think this not related to DHCP or static ip.

 

0 Kudos
cleston_tellis
Contributor
Contributor

 @milindng, it is not related to DHCP or static ip as the vcenter vm will be given an A dns record on your dns server, so that is fine.

open putty and ssh to the vcenter vm.

than locate the host file /etc/hosts/

add the below record in the host file /etc/hosts/ to fix the issue...

127.0.0.1 (FQN name here vcsa.***.local) vcsa localhost

 

save and reboot the VM.

0 Kudos
grumpyboy
Contributor
Contributor

I also had this problem, turned out it just takes quite a long time for vCenter server to finish booting up ( about 20mins! ). You can can login via root (ssh) and wait untill the CPU useage goes low again, thats when its finished.

After 20mins wait the CPU had gone to normal and I checked the vCenter URL again and this time all was normal and working!

 

0 Kudos
Long9499
Contributor
Contributor

I got the same error, i found a thread on somewhere on google and they said it could be because the ipv4 was set to DHCP, so i checked it under Networking -> Networking Settings -> Edit, but it was Static since the beginning, so i leave it there and finish editing, Networking restart and kaboom the error gone. So i think if facing this you guys can do these:

- Check DNS server

- Check Client and Networking service

- Restart Networking service

0 Kudos
Ajay1988
VMware Employee
VMware Employee

This is not an issue with vCSA. Please wait for all services to be up. Monitor the VAMI page and validate all services are up and then only connect to VC using HTML. Otherwise that error is expected. I have see in my lab services taking 10-15 mins after vCSA reboot(It can vary even).

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
Tags (3)
Long9499
Contributor
Contributor

Yes you are right, i did a check and wait for about 10 mins after vCSA start, the Web Cient working perfectly, also there is a trick that you guys could pay attention to how much memory vCSA consume, for example, my vCSA working normally with all services up take about more than 10 gbs, so when my vCSA use 10 gbs of memory, i know that the time i can use Web Client

Tags (1)
0 Kudos
Marv1
Contributor
Contributor

Hi All I had the same issue here after I reconfigured the DNS server

I tried logging in with just the ip address but never worked not matter what I tried, I decided to add the port at the end of the ip address...... ie..192.168.34.2:5480 and it worked perfectly fine

PS: it was working fine before I changed the ip address and the DNS

Hey i'm Marv by the... just too lazy to create an account

0 Kudos
aljbali
Contributor
Contributor

same here, I made some changes to my DNS router ( added pfsense ) that broke my vCenter7

0 Kudos
vgarczynski
Contributor
Contributor

I had the same issue when i just used https://<vCenter IP> , but when I added the /ui to the url it worked.

0 Kudos
vgarczynski
Contributor
Contributor

After logging in to the VAMI i found that the /storage/seat disk was over 95% full Once that was fixed I no longer got the no healthy upstream message

0 Kudos
sasolwintelteam
Contributor
Contributor

Only run this cmd after installation from a putty session with vcentre server , i got this problem 8 time and evrytime this command sorted . 
service-control --start --all

0 Kudos
TALAC
Contributor
Contributor

Hello, Me for this same problem I just put the host and the VCSA on the same time zone and at the same time. Hop it worked

0 Kudos
Atallah92
Contributor
Contributor

for me i just add the port 5480 then go to services and restart the vAPI endpoint, it works every time hope it helps.

0 Kudos
avenonet
Contributor
Contributor

/usr/lib/vmware-vmca/bin/certificate-manager

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 

|                                                                     |

|      *** Welcome to the vSphere 6.8 Certificate Manager  ***        |

|                                                                     |

|                   -- Select Operation --                            |

|                                                                     |

|      1. Replace Machine SSL certificate with Custom Certificate     |

|                                                                     |

|      2. Replace VMCA Root certificate with Custom Signing           |

|         Certificate and replace all Certificates                    |

|                                                                     |

|      3. Replace Machine SSL certificate with VMCA Certificate       |

|                                                                     |

|      4. Regenerate a new VMCA Root Certificate and                  |

|         replace all certificates                                    |

|                                                                     |

|      5. Replace Solution user certificates with                     |

|         Custom Certificate                                          |

|         NOTE: Solution user certs will be deprecated in a future    |

|         release of vCenter. Refer to release notes for more details.|

|                                                                     |

|      6. Replace Solution user certificates with VMCA certificates   |

|                                                                     |

|      7. Revert last performed operation by re-publishing old        |

|         certificates                                                |

|                                                                     |

|      8. Reset all Certificates                                      |

|_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _|

Note : Use Ctrl-D to exit.

Option[1 to 8]: 8

 

 

for me this is what I had to do then from here you are good to go and make sure to set your calendars to renew the certs! 

0 Kudos
sofoniyas
Contributor
Contributor

0 Kudos
Burti
Contributor
Contributor

I was buy the dedicated server https://www.burtinet.com and I installed vCenter but its showing this error. How can I fix it?

Tags (1)
0 Kudos
Ajay1988
VMware Employee
VMware Employee

Please start a new post. "no healthy upstream" is a very generic thing. Mostly means VC services are not up. 

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
MarcelFernandez
Contributor
Contributor

Recently encountered this error. logged on to host and upgraded vmware hardware compatibility - change os family to photon os. This caused no change, but might as well set.

what did work was that certs had expired and didn't auto renew. please look at the following link to check your certs and renew:

vCenter Server 7.0 HTML5 UI error “no healthy upstream” – vElements.net

0 Kudos
usmguy04
Contributor
Contributor

For me, this was because I had changed the time zone on my vcsa from UTC to my local time zone. I changed it back to UTC, rebooted, and everything was fine.

0 Kudos
Sameer0619
Contributor
Contributor

i restarted the service Services>VMware vCenter Server and it works .

hope this will help.