Highlighted
Contributor
Contributor

vCenter 7.0.0.10400 patch to 7.0.0.10700. Packages in appliance are up to date with update payload, Nothing to stage

Trying to patch vCenter 7.0.0.10400 to 7.0.0.10700.  Mount VMware-vCenter-Server-Appliance-7.0.0.10700-16749653-patch-FP.iso via VMRC (Local Client) & when I run Command> software-packages stage --iso I get:

Using username "root".

Pre-authentication banner message from server:

|

| VMware vCenter Server 7.0.0.10400

|

| Type: vCenter Server with an embedded Platform Services Controller

|

End of banner message from server

Last login: Sun Sep  6 16:43:11 2020 from 192.168.0.53

Connected to service

    * List APIs: "help api list"

    * List Plugins: "help pi list"

    * Launch BASH: "shell"

Command> software-packages stage --iso

[2020-09-06T16:57:29.250] : ISO mounted successfully

[2020-09-06T16:57:33.250] : Not running on a VMC Gateway appliance.

[2020-09-06T16:57:33.250] : Not running on a VMC Gateway appliance.

[2020-09-06T16:57:33.250] : Target VCSA version = 7.0.0.10700

[2020-09-06T16:57:33.250] : Not running on a VMC Gateway appliance.

[2020-09-06T16:57:33.250] : No manifest whitelist present, it is not leaf service upgrade.

[2020-09-06T16:57:33.250] : Not running on a VMC Gateway appliance.

[2020-09-06T16:57:33.250] : Not running on a VMC Gateway appliance.

[2020-09-06T16:57:33.250] : Not running on a VMC Gateway appliance.

[2020-09-06T16:57:33.250] : Not running on a VMC Gateway appliance.

[2020-09-06T16:57:33.250] : Checking if HLM is enabled

[2020-09-06T16:57:33.250] : Product configuration file does not exists.

[2020-09-06T16:57:33.250] : Filtering components as not all are allowed to run. Whitelist []

Blacklist []

[2020-09-06T16:57:34.250] : Not running on a VMC Gateway appliance.

[2020-09-06T16:57:34.250] : Not running on a VMC Gateway appliance.

[2020-09-06T16:57:34.250] : About to perform WCP checks

[2020-09-06T16:57:34.250] : Performing WCP checks

[2020-09-06T16:57:34.250] : Adding WCP path to Python path

[2020-09-06T16:57:34.250] : Found Kubernetes versions {'1.18', '1.16', '1.17'} in /storage/core/software-packages/scripts/patches/payload/components-script/wcp/wcp_versions.yaml

[2020-09-06T16:57:34.250] : Found Kubernetes versions {'1.18', '1.16', '1.17'} in /etc/vmware/wcp/wcp_versions.yaml

[2020-09-06T16:57:34.250] : Incoming patch does not introduce new k8s versions, at-risks cluster check skipped.

[2020-09-06T16:57:34.250] : Done performing WCP checks

[2020-09-06T16:57:34.250] : WCP checks finished

[2020-09-06 16:57:34,736] : Running requirements script.....

[2020-09-06T16:57:38.250] : Checking if HLM is enabled

[2020-09-06T16:57:39.250] : ISO unmounted successfully

[2020-09-06T16:57:39.250] : Packages in appliance are up to date with update payload, Nothing to stage

0 Kudos
4 Replies
Highlighted
Commander
Commander

Hello Dave,

If you run the next command what does it shows you: software-packages list --staged --verbose

Also you can run the whole patch from the VAMI. Simply follow the next procedure which is really short: https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vcenter.upgrade.doc/GUID-FF533442-66F0-4797...

0 Kudos
Highlighted
Contributor
Contributor

Hello

Command> software-packages list --staged --verbose

[2020-09-07T14:32:17.251] : Packages not staged

*******

Nothing gets staged in my original command.  software-packages stage --iso cmd returns "Nothing to stage"

As you can see below my appliance is 7.0.0.10400 yet the patch iso I have mounted is VMware-vCenter-Server-Appliance-7.0.0.10700-16749653-patch-FP.iso

pastedImage_2.png

I originally tried to use the Management console:

pastedImage_0.png

I get:

pastedImage_1.png

However my vCenter appears to be functioning fine.  I was hoping CLI would give me more verbose information.

0 Kudos
Highlighted
Commander
Commander

0 Kudos
Highlighted
Contributor
Contributor

Hello Lalegre

Deleted "/etc/applmgmt/appliance/software_update_state.conf" & reran the update to 7.0.0.10700 from the Management UI.  Now the GUI  & software-packages think my appliance is already at 7.0.0.10700. 

pastedImage_0.png

I've tried to run the update of 7.0.0.10700 before but it's never completed successfully.  I think I'm in the middle of that up. 

vpxd is at build 16749670 (7.0.0.10700)

root@vCenter [ /etc/applmgmt/appliance ]# vpxd -v

VMware VirtualCenter 7.0.0 build-16749670

But the appliance Server Manager thinks it's at 7.0.0.10400

pastedImage_2.png

0 Kudos