vCenter 5.5 Web Client shows incorrect inventory

Jump to solution

I upgraded my vCenter to 5.5 from 5.1 and it works except the Web Client has incorrect inventory data.  It is missing some VMs and has some ghost VMs that don't actually exist.  There aren't any error messages that suggest the server is malfunctioning.  The really strange thing is that when I connect with the vSphere Client on Windows, everything is correct there.  Also Veeam shows all the correct inventory when it connects to the vCenter server.  So its only the Web Client that is wrong.  Has anyone experienced this or have any ideas on how to force the Web Client to refresh?

edit: forgot to mention this is VCSA

31 Replies

same here mates (and we have date 2014-02-21),

so, what's not working good and after what:

- differences between vm and folders inventory between web client and vcenter client

- in generally after some time no new registration of vms shows in web client, not matter where they ware created/registered

- deleted vm's are still in web client inventory

- any restart of any vcenter services, even a host not help

- it was clean installation of vcenter 5.5

- after problem occurs it was updated to newest version of vcenter 5.5.1476327 - not helped

- I'm not so sure but problem may start to occur (im sure on 40%) after installing VDP Advanced, and then after reinstall it because it not working ok (everything lower than cluster showed "not licensed"), then I observe that new VDP not register to vcenter (web client), additionally my host was disconnect from vcenter and i have to reconnect it, it was probably before I observe the problem (with not registered next VDP)

- then i start searching a web, found your posts, nice work

- now problem solved, and here are what I done:

1.     posts a solution that probably works bests:

service vmware-inventoryservice stop
# Remove stored data:
rm -rf /storage/db/inventoryservice/data
/usr/lib/vmware-vpx/inventoryservice/scripts/ -Dvim.logdir=/var/log/vmware/vpx/inventoryservice com.vmware.vim.dataservices.CreateDb /storage/db/inventoryservice/data changeme default changeme
service vmware-inventoryservice start

/usr/lib/vmware-vpx/inventoryservice-registration/ -Dvim.logdir=/var/log/vmware/vpx/inventoryservice-registration com.vmware.vim.dataservices.vcregtool.RegisterVC -action register -lookupserviceurl https://$vcenterhost:7444/lookupservice/sdk -isurl https://$vcenterhost:10443 -vcurl https://$vcenterhost/sdk/vimService -vccert /etc/vmware-vpx/ssl/rui.crt -vcprivkey /etc/vmware-vpx/ssl/rui.key -vcinstancecfg /etc/vmware-vpx/instance.cfg -vcendpointsdir /usr/lib/vmware-vpx/endpoints -vcextensionsdir /usr/lib/vmware-vpx/extensions
service vmware-vpxd restart

2. but, after that from my 258 vms before (and 274 vms in truly) left only 58 vms... not so pretty... but I thought it may be connected to some other vcenter cache and logs and restart vcenter... not sure that ware help but additionally (and in my opinion that helps) I disconnect and connect again my host and then every 272 vms appear again and now it looks like working ok for now.

thanks mates for good topic and hope it helps a little to others.



0 Kudos

We constantly have this issue every 4-6 weeks with the appliance.

Suddenly the inventory is wrong at the vspere webclient. But only there, the standard client still works with correct inventory.

But also VDP stops working (error = host is in a state which prevents creating snapshots). Normal snapshots still work.

This usually happens when restarting the vcenter appliance after some weeks. Sometimes after vmotion of vcenter.

Our workaround:

1. rename vcenter to vcenter-old (with standard client)

2. clone vcenter-old to another host as vcenter

3. shutdown vcenter-old

4. powerup vcenter

5. if everything works delete vcenter-old and reconfigure VDP to backup the new appliance.

0 Kudos

Hi guys,

Same problem here! I'm using VCSA 5.1U2.

Someone have news or some workaround that really works?

We've done 2 refresh installs and the problem appears in both environments.

0 Kudos

We having similar issue only we are not using the appliance. We recently installed our new vCenter server 5.5. It is working fine from the regular vCenter means we can see all the inventory but using the Web Client we cannot see the VMs. We don't know what could be the problem. Any suggestion! 

0 Kudos

This fixed my issue as well! Had to recut all vCSA certificates using OpenSSL 0.9.8y (instead of 1.0.1g) and everything's working again! (had really weird issues where vSphere Client showed the inventory but Web Client was blank and/or reported inventory service registration errors).

thank you Tanya!


0 Kudos

We had problems with the vSphere client (not the webclient) :

-Inventory filled up the disk volume because it was writing logs (xhive) on the drive -> result server crash

-Web client shows outdated data even if you create new items in the web client they will not show up

-Loading.... showing in the vSphere client, especially after a reboot of vCenter.. not showing VMs, Datastores and Network on certain hosts.

-Reinstall of vCenter, didnt work.

-Change of SQL server didnt work.

-Strange behaviour with VDP, Not able to backup because of license errors and core service shuts down

Turned out to be vFRC, after disabling all disks on all hosts the problem went away, Should be resolved in 5.5 u2
VMware KB: After enabling Virtual Flash, VMware vCenter Server 5.5 consumes most of the CPU, memory,...

0 Kudos

I had this issue with vCenter Appliances 5.5.

Resetting Inventory database fixed the issue. Here is the KB

0 Kudos

You can solve the "Cannot read VC private key file /etc/vmware-vpx/ssl/rui.key" by converting your key from the "new" OpenSSL 1.0x default format (PKCS#8) to the "old" OpenSSL 0.9.8 default format (PEM/topk8).

cd /etc/vmware-vpx/ssl/

mv rui.key rui.key.pkcs

openssl rsa -in rui.key.pkcs -text > rui.key

now open the rui.key with vi and delete all lines before


Your private key is now in the correct format.

0 Kudos

Hello everyone,

I also HAD these same issues. Landed up rebuilding the Win2008R2 server 3 times to get a clean install everytime.

Got the same issues as everyone reported everytime.

Good news is my issue is now resolved. All I did was change the "VMware vcenter inventory service" to login as the "administrator of the domain".

So it was a rights issue for me but not 100% clear what was failing.

Hope this helps guys.


0 Kudos

I had this same problem and changing the key type to pkcs1 format fixed it.

To your comment on how to convert it, if you use the following you do not need to edit the file to remove all the extraneous data.

openssl rsa -in rui.key.pkcs -out rui.key

will generate the correct file format.

I found today that this is listed at the top of the KB article I used to replace the certificates, VMware KB: Configuring Certificate Authority (CA) signed certificates for vCenter Server Appliance 5....

0 Kudos

Hi esteretereteestereterete,

thanks - that's help for me too. Smiley Happy

Best Regards,


0 Kudos


I have the same problem with vcenter server 5.5. The server manage 3 ESXi hosts which are in production and host 150-160 VMs.

So I want to know what is the impact for the Virtual machines during/after resting the inventory database?

For me is very important virtual machines to be running  without any interruptions.

What will happening with distributed switch configurations, alarms and etc settings after the reset?

Thank you in advance!

0 Kudos